<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Zeogar Wilson’s Reckless and Irresponsible Attacks on Nimba County | Liberian Observer</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://www.liberianobserver.com/xmlrpc.php" />

<link rel="manifest" href="/superpwa-manifest.json">
<meta name="theme-color" content="#D5E0EB">
<link rel="apple-touch-icon" sizes="192x192" href="https://www.liberianobserver.com/wp-content/uploads/2018/12/libobserver-icon.png">
<link rel="apple-touch-icon" sizes="512x512" href="https://www.liberianobserver.com/wp-content/uploads/2018/12/libobserver-splashscreen.jpg">

<style>
/* Custom BSA_PRO Styles */
/* fonts */
/* form */
.bsaProOrderingForm {   }
.bsaProInput input,
.bsaProInput input[type='file'],
.bsaProSelectSpace select,
.bsaProInputsRight .bsaInputInner,
.bsaProInputsRight .bsaInputInner label {   }
.bsaProPrice  {  }
.bsaProDiscount  {   }
.bsaProOrderingForm .bsaProSubmit,
.bsaProOrderingForm .bsaProSubmit:hover,
.bsaProOrderingForm .bsaProSubmit:active {   }
/* alerts */
.bsaProAlert,
.bsaProAlert > a,
.bsaProAlert > a:hover,
.bsaProAlert > a:focus {  }
.bsaProAlertSuccess {  }
.bsaProAlertFailed {  }
/* stats */
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-bar,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-line,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-point,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-slice.ct-donut { stroke: #673AB7 !important; }
.bsaStatsWrapper  .ct-chart .ct-series.ct-series-a .ct-bar,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-line,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-point,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-slice.ct-donut { stroke: #FBCD39 !important; }
/* Custom CSS */
</style><link rel="icon" type="image/png" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png" /><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Liberian Observer &raquo; Feed" href="https://www.liberianobserver.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Liberian Observer &raquo; Comments Feed" href="https://www.liberianobserver.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Liberian Observer &raquo; Zeogar Wilson’s Reckless and Irresponsible Attacks on Nimba County Comments Feed" href="https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.liberianobserver.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3"}};
!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
display: inline !important;
border: none !important;
box-shadow: none !important;
height: 1em !important;
width: 1em !important;
margin: 0 .07em !important;
vertical-align: -0.1em !important;
background: none !important;
padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-components-css' href='https://c0.wp.com/c/5.3/wp-includes/css/dist/components/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-font-css' href='https://fonts.googleapis.com/css?family=Noto+Serif%3A400%2C400i%2C700%2C700i&#038;ver=5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-editor-css' href='https://c0.wp.com/c/5.3/wp-includes/css/dist/block-editor/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-nux-css' href='https://c0.wp.com/c/5.3/wp-includes/css/dist/nux/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-css' href='https://c0.wp.com/c/5.3/wp-includes/css/dist/editor/style.min.css' type='text/css' media='all' />












<link rel="stylesheet" type="text/css" href="//www.liberianobserver.com/wp-content/cache/wpfc-minified/qx4iczaf/26xd3.css" media="all" />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;display=swap&#038;ver=10.2' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='vc_lte_ie9-css'  href='https://www.liberianobserver.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.5' type='text/css' media='screen' />
<![endif]-->
<link rel='stylesheet' id='td-theme-css' href='https://www.liberianobserver.com/wp-content/themes/loc-theme/style.css?ver=9.2.2.1547643655' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
@media (max-width: 767px) {
.td-header-desktop-wrap {
display: none;
}
}
@media (min-width: 767px) {
.td-header-mobile-wrap {
display: none;
}
}
</style>

<link rel="stylesheet" type="text/css" href="//www.liberianobserver.com/wp-content/cache/wpfc-minified/fpd10xya/c0iq6.css" media="all" />
<style id='__EPYT__style-inline-css' type='text/css'>
.epyt-gallery-thumb {
width: 33.333%;
}
</style>





<link rel="stylesheet" type="text/css" href="//www.liberianobserver.com/wp-content/cache/wpfc-minified/er1vf2qa/fjcqa.css" media="all" />
<link rel='stylesheet' id='social-logos-css' href='https://c0.wp.com/p/jetpack/7.9.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/7.9.1/css/jetpack.css' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.liberianobserver.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/thickbox/thickbox.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/underscore.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/shortcode.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-admin/js/media-upload.min.js'></script>
<script src='//www.liberianobserver.com/wp-content/cache/wpfc-minified/kc6ufyus/c0iq6.js' type="text/javascript"></script>





<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/www.liberianobserver.com\/wp-admin\/admin-ajax.php","security":"9a90197c60","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/www.liberianobserver.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/www.liberianobserver.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"13.1.2.4","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script src='//www.liberianobserver.com/wp-content/cache/wpfc-minified/5blhjl3/c0iq6.js' type="text/javascript"></script>

<link rel='https://api.w.org/' href='https://www.liberianobserver.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.liberianobserver.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.liberianobserver.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Liberia Win 3rd-Place in WAFU Women&#8217;s Tourney, Defeat Cape Verde 1-0' href='https://www.liberianobserver.com/news/liberia-win-3rd-place-in-wafu-womens-tourney-defeat-cape-verde-1-0/' />
<link rel='next' title='STOP Using Generators inside Your Home: If You Don’t, You and Your Family Will Die!' href='https://www.liberianobserver.com/opinion/editorials/stop-using-generators-inside-your-home-if-you-dont-you-and-your-family-will-die/' />
<link rel="canonical" href="https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/" />
<link rel='shortlink' href='https://wp.me/p8u3gB-BXb' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
window.tdb_globals = {"wpRestNonce":"b1609162ac","wpRestUrl":"https:\/\/www.liberianobserver.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
</script>
<script>
window.tdwGlobal = {"adminUrl":"https:\/\/www.liberianobserver.com\/wp-admin\/","wpRestNonce":"b1609162ac","wpRestUrl":"https:\/\/www.liberianobserver.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
</script>
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style> <meta name="onesignal" content="wordpress-plugin" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>
window.OneSignal = window.OneSignal || [];
OneSignal.push( function() {
OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };
OneSignal.setDefaultNotificationUrl("https://www.liberianobserver.com");
var oneSignal_options = {};
window._oneSignalInitOptions = oneSignal_options;
oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '30a33a75-54af-4faf-beb9-c8fced7ae582';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.liberianobserver.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "liberianobserver.com";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'inverse';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['text']['message.prenotify'] = 'Subscribe the latest news stories';
oneSignal_options['notifyButton']['text']['tip.state.subscribed'] = 'You&#039;re subscribed to the latest stories';
OneSignal.init(window._oneSignalInitOptions);
});
function documentInitOneSignal() {
var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");
var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
}
if (document.readyState === 'complete') {
documentInitOneSignal();
}
else {
window.addEventListener("load", function(event){
documentInitOneSignal();
});
}
</script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<style type="text/css">
/* If html does not have either class, do not show lazy loaded images. */
html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
display: none;
}
</style>
<script>
document.documentElement.classList.add(
'jetpack-lazy-images-js-enabled'
);
</script>

<meta property="og:type" content="article" />
<meta property="og:title" content="Zeogar Wilson’s Reckless and Irresponsible Attacks on Nimba County" />
<meta property="og:url" content="https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/" />
<meta property="og:description" content="A Nimba Citizen’s Response &#8212; Part One By Kadiker Rex Dahn, MA, M.Ed, PhD Background Certainly, there are individuals in the George Weah’s led government who relentlessly continue to make dero…" />
<meta property="article:published_time" content="2020-03-10T02:16:00+00:00" />
<meta property="article:modified_time" content="2020-03-10T01:14:46+00:00" />
<meta property="og:site_name" content="Liberian Observer" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />

<meta name="twitter:partner" content="tfwp">

<script>
var tdBlocksArray = []; //here we store all the items for the current page
//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
this.id = '';
this.block_type = 1; //block type id (1-234 etc)
this.atts = '';
this.td_column_number = '';
this.td_current_page = 1; //
this.post_count = 0; //from wp
this.found_posts = 0; //from wp
this.max_num_pages = 0; //from wp
this.td_filter_value = ''; //current live filter value
this.is_ajax_running = false;
this.td_user_action = ''; // load more or infinite loader (used by the animation)
this.header_color = '';
this.ajax_pagination_infinite_stop = ''; //show load more at page x
}
// td_js_generator - mini detector
(function(){
var htmlTag = document.getElementsByTagName("html")[0];
if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
htmlTag.className += ' ie10';
}
if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
htmlTag.className += ' ie11';
}
if ( navigator.userAgent.indexOf("Edge") > -1 ) {
htmlTag.className += ' ieEdge';
}
if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
htmlTag.className += ' td-md-is-ios';
}
var user_agent = navigator.userAgent.toLowerCase();
if ( user_agent.indexOf("android") > -1 ) {
htmlTag.className += ' td-md-is-android';
}
if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
htmlTag.className += ' td-md-is-os-x';
}
if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
htmlTag.className += ' td-md-is-chrome';
}
if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
htmlTag.className += ' td-md-is-firefox';
}
if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
htmlTag.className += ' td-md-is-safari';
}
if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
htmlTag.className += ' td-md-is-iemobile';
}
})();
var tdLocalCache = {};
( function () {
"use strict";
tdLocalCache = {
data: {},
remove: function (resource_id) {
delete tdLocalCache.data[resource_id];
},
exist: function (resource_id) {
return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
},
get: function (resource_id) {
return tdLocalCache.data[resource_id];
},
set: function (resource_id, cachedData) {
tdLocalCache.remove(resource_id);
tdLocalCache.data[resource_id] = cachedData;
}
};
})();
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";
var tdc_is_installed="yes";
var td_ajax_url="https:\/\/www.liberianobserver.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=10.2";
var td_get_template_directory_uri="https:\/\/www.liberianobserver.com\/wp-content\/plugins\/td-composer\/legacy\/common";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="show";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#4db2ec";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdBlockNonce="fd0f42a269";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-16946754-1', 'auto');
ga('send', 'pageview');
</script>
<meta name="twitter:card" content="summary"><meta name="twitter:title" content="Zeogar Wilson’s Reckless and Irresponsible Attacks on Nimba County"><meta name="twitter:description" content="A Nimba Citizen’s Response -- Part One By Kadiker Rex Dahn, MA, M.Ed, PhD Background Certainly, there are individuals in the George Weah’s led government who relentlessly continue to make derogatory, reckless and irresponsible statements against others. One does not need to be a rocket scientist to ascertain such fact. Periodic verbal attacks against citizens&hellip;">
<style type="text/css" id="wp-custom-css">
/*
You can add your own CSS here.
Click the help icon above to learn more.
*/
.cl-popup-trigger img{margin: 5px;}			</style>

<style>
</style>
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript> <style id="tdw-css-placeholder"></style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-145897 single-format-standard td-standard-pack zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county global-block-template-1 single_template_1 wpb-js-composer js-comp-ver-6.0.5 vc_responsive td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/pages/Liberian-Observer-Online/42279623238" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/libobserver/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.titter.com/libobserver" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/locmultimedia" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-28638" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-28638"><a href="https://www.liberianobserver.com">Home</a></li>
<li id="menu-item-28617" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28617"><a href="https://www.liberianobserver.com/./news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><a href="https://www.liberianobserver.com/./news/development/">Development</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/diaspora/">Diaspora</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/legal/">Legal</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/local/">Local</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/media/">Media</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/politics/">Politics</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/security/">Security</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/west-africa/">West Africa</a></li>
</ul>
</li>
<li id="menu-item-28585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28585"><a href="https://www.liberianobserver.com/./business/">Business<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./business/investment/">Investment</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./business/markets/">Markets</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./business/opportunities/">Opportunities</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./business/the-economy/">The Economy</a></li>
</ul>
</li>
<li id="menu-item-28623" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-28623"><a href="https://www.liberianobserver.com/./opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./opinion/cartoon/">Cartoon</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./opinion/commentaries/">Commentaries</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./opinion/editorials/">Editorials</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./opinion/letters/">Letters</a></li>
</ul>
</li>
<li id="menu-item-28628" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28628"><a href="https://www.liberianobserver.com/./sports/">Sports<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/athlete-profiles/">Athlete Profiles</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/basketball/">Basketball</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/football/">Football</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/leagues/">Leagues</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/sports-administration/">Sports Administration</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/track-field/">Track &amp; Field</a></li>
</ul>
</li>
<li id="menu-item-28590" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28590"><a href="https://www.liberianobserver.com/./columns/">Columns<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/agriculture/">Agriculture</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/education/">Education</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/environment/">Environment</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/health/">Health</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/religion/">Religion</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/technology/">Technology</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/women/">Women</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/youth/">Youth</a></li>
</ul>
</li>
<li id="menu-item-28604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28604"><a href="https://www.liberianobserver.com/./lib-life/">LIB Life<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/arts/">Arts</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/entertainment/">Entertainment</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/history-us/">History &amp; Us</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/people/">People</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/poetry/">Poetry</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/short-story/">Short Story</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/style/">Style</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/travel/">Travel</a></li>
</ul>
</li>
<li id="menu-item-28622" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28622"><a href="https://www.liberianobserver.com/./obituaries/">Obituaries</a></li>
<li id="menu-item-78579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78579"><a href="https://www.liberianobserver.com/dev-matters/">Dev Matters</a></li>
<li id="menu-item-50465" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50465"><a href="http://liberiapromisetracker.com/">Election Promises</a></li>
</ul></div> </div>
</div>

<div id="login-form-mobile" class="td-register-section">
<div id="td-login-mob" class="td-login-animation td-login-hide-mob">

<div class="td-login-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Sign in</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
<div class="td-login-info-text">
<a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
</div>
<div class="td-login-register-link">
</div>
</div>
</div>
<div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">

<div class="td-forgot-pass-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Password recovery</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
</div>
</div>
</div>
</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://www.liberianobserver.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-1 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-28852" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-28852"><a href="https://www.scribd.com/Liberian%20Daily%20Observer">E-Edition</a></li>
<li id="menu-item-28964" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-28964"><a href="https://www.liberianobserver.com/wp-login.php">Login</a></li>
<li id="menu-item-28965" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home td-menu-item td-normal-menu menu-item-28965"><a href="https://www.liberianobserver.com">Advertisements</a></li>
<li id="menu-item-28966" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home td-menu-item td-normal-menu menu-item-28966"><a href="https://www.liberianobserver.com">Archives</a></li>
<li id="menu-item-69499" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-69499"><a href="https://www.liberianobserver.com/opportunities/">Opportunities</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/pages/Liberian-Observer-Online/42279623238" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/libobserver/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.titter.com/libobserver" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/locmultimedia" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
<div class="td-container td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.liberianobserver.com/">
<img class="td-retina-data" data-retina="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" src="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" alt="Daily Observer Logo" title="Daily Observer" />
<span class="td-visual-hidden">Liberian Observer</span>
</a>
</div>
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header tdi_1_885 td_block_template_1 ">
<style>
/* custom css */
.tdi_1_885.td-a-rec-img{
text-align: left;
}.tdi_1_885.td-a-rec-img img{
margin: 0 auto 0 0;
}
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;
if ( td_screen_width >= 1140 ) {
/* large monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="3254916944"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
/* landscape tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="3254916944"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
/* portrait tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="3254916944"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width < 768 ) {
/* Phones */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="3254916944"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>

</div> </div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient ">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-header" href="https://www.liberianobserver.com/">
<img class="td-retina-data" data-retina="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" src="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" alt="Daily Observer Logo" title="Daily Observer" />
</a>
<a class="td-header-logo td-sticky-header" href="https://www.liberianobserver.com/">
<img class="td-retina-data" data-retina="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" src="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" alt="Daily Observer Logo" title="Daily Observer" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-28638"><a href="https://www.liberianobserver.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-28617"><a href="https://www.liberianobserver.com/./news/">News</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_2_56c td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_2_56c"><script>var block_tdi_2_56c = new tdBlock();
block_tdi_2_56c.id = "tdi_2_56c";
block_tdi_2_56c.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"544","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_2_56c","tdc_css_class":"tdi_2_56c","tdc_css_class_style":"tdi_2_56c_rand_style"}';
block_tdi_2_56c.td_column_number = "3";
block_tdi_2_56c.block_type = "td_block_mega_menu";
block_tdi_2_56c.post_count = "4";
block_tdi_2_56c.found_posts = "17011";
block_tdi_2_56c.header_color = "";
block_tdi_2_56c.ajax_pagination_infinite_stop = "";
block_tdi_2_56c.max_num_pages = "4253";
tdBlocksArray.push(block_tdi_2_56c);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_2_56c" id="tdi_3_4c5" data-td_block_id="tdi_2_56c" data-td_filter_value="" href="https://www.liberianobserver.com/./news/">All</a><a class="mega-menu-sub-cat-tdi_2_56c" id="tdi_4_344" data-td_block_id="tdi_2_56c" data-td_filter_value="904" href="https://www.liberianobserver.com/./news/development/">Development</a><a class="mega-menu-sub-cat-tdi_2_56c" id="tdi_5_4ed" data-td_block_id="tdi_2_56c" data-td_filter_value="1035" href="https://www.liberianobserver.com/./news/diaspora/">Diaspora</a><a class="mega-menu-sub-cat-tdi_2_56c" id="tdi_6_50b" data-td_block_id="tdi_2_56c" data-td_filter_value="667" href="https://www.liberianobserver.com/./news/legal/">Legal</a><a class="mega-menu-sub-cat-tdi_2_56c" id="tdi_7_e47" data-td_block_id="tdi_2_56c" data-td_filter_value="905" href="https://www.liberianobserver.com/./news/local/">Local</a><a class="mega-menu-sub-cat-tdi_2_56c" id="tdi_8_645" data-td_block_id="tdi_2_56c" data-td_filter_value="1045" href="https://www.liberianobserver.com/./news/media/">Media</a><a class="mega-menu-sub-cat-tdi_2_56c" id="tdi_9_0fc" data-td_block_id="tdi_2_56c" data-td_filter_value="553" href="https://www.liberianobserver.com/./news/politics/">Politics</a><a class="mega-menu-sub-cat-tdi_2_56c" id="tdi_10_6f4" data-td_block_id="tdi_2_56c" data-td_filter_value="555" href="https://www.liberianobserver.com/./news/security/">Security</a><a class="mega-menu-sub-cat-tdi_2_56c" id="tdi_11_566" data-td_block_id="tdi_2_56c" data-td_filter_value="1041" href="https://www.liberianobserver.com/./news/west-africa/">West Africa</a></div></div><div id=tdi_2_56c class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/dont-kill-senator-dillons-brother-without-giving-him-due-processes/" rel="bookmark" class="td-image-wrap" title="‘Don’t Kill Senator Dillon’s Brother Without Giving Him Due Processes’"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="‘Don’t Kill Senator Dillon’s Brother Without Giving Him Due Processes’" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Cllr.-Toe.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/legal/" class="td-post-category">Legal</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/dont-kill-senator-dillons-brother-without-giving-him-due-processes/" rel="bookmark" title="‘Don’t Kill Senator Dillon’s Brother Without Giving Him Due Processes’">‘Don’t Kill Senator Dillon’s Brother Without Giving Him Due Processes’</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/prez-weah-pledges-support-to-ellen-sirleaf-presidential-center/" rel="bookmark" class="td-image-wrap" title="Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Presidnet-Weah-and-former-President-Sirleaf-at-the-launch-of-her-Amujae-Initiative.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/prez-weah-pledges-support-to-ellen-sirleaf-presidential-center/" rel="bookmark" title="Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center">Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/criminal-conveyance-of-land-may-undermine-national-security/" rel="bookmark" class="td-image-wrap" title="‘Criminal Conveyance of Land May Undermine National Security’"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="‘Criminal Conveyance of Land May Undermine National Security’" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2017/05/Chief-justice-Korkpor-1.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/legal/" class="td-post-category">Legal</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/criminal-conveyance-of-land-may-undermine-national-security/" rel="bookmark" title="‘Criminal Conveyance of Land May Undermine National Security’">‘Criminal Conveyance of Land May Undermine National Security’</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/former-pres-sirleaf-authorized-disbursement-of-afls-pension-money/" rel="bookmark" class="td-image-wrap" title="‘Former Pres. Sirleaf Authorized Disbursement of AFL’s Pension Money’"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="‘Former Pres. Sirleaf Authorized Disbursement of AFL’s Pension Money’" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2017/06/Defense-Minister-Brownie-J.-Samukai-Jr..jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/legal/" class="td-post-category">Legal</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/former-pres-sirleaf-authorized-disbursement-of-afls-pension-money/" rel="bookmark" title="‘Former Pres. Sirleaf Authorized Disbursement of AFL’s Pension Money’">‘Former Pres. Sirleaf Authorized Disbursement of AFL’s Pension Money’</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_2_56c" data-td_block_id="tdi_2_56c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_2_56c" data-td_block_id="tdi_2_56c"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-28585"><a href="https://www.liberianobserver.com/./business/">Business</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_12_544 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_12_544"><script>var block_tdi_12_544 = new tdBlock();
block_tdi_12_544.id = "tdi_12_544";
block_tdi_12_544.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"551","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_12_544","tdc_css_class":"tdi_12_544","tdc_css_class_style":"tdi_12_544_rand_style"}';
block_tdi_12_544.td_column_number = "3";
block_tdi_12_544.block_type = "td_block_mega_menu";
block_tdi_12_544.post_count = "4";
block_tdi_12_544.found_posts = "4492";
block_tdi_12_544.header_color = "";
block_tdi_12_544.ajax_pagination_infinite_stop = "";
block_tdi_12_544.max_num_pages = "1123";
tdBlocksArray.push(block_tdi_12_544);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_12_544" id="tdi_13_540" data-td_block_id="tdi_12_544" data-td_filter_value="" href="https://www.liberianobserver.com/./business/">All</a><a class="mega-menu-sub-cat-tdi_12_544" id="tdi_14_5b2" data-td_block_id="tdi_12_544" data-td_filter_value="558" href="https://www.liberianobserver.com/./business/investment/">Investment</a><a class="mega-menu-sub-cat-tdi_12_544" id="tdi_15_f4f" data-td_block_id="tdi_12_544" data-td_filter_value="559" href="https://www.liberianobserver.com/./business/markets/">Markets</a><a class="mega-menu-sub-cat-tdi_12_544" id="tdi_16_564" data-td_block_id="tdi_12_544" data-td_filter_value="560" href="https://www.liberianobserver.com/./business/opportunities/">Opportunities</a><a class="mega-menu-sub-cat-tdi_12_544" id="tdi_17_c14" data-td_block_id="tdi_12_544" data-td_filter_value="557" href="https://www.liberianobserver.com/./business/the-economy/">The Economy</a></div></div><div id=tdi_12_544 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/gol-to-launch-4g-data-voice-services-in-remote-parts-of-gbarpolu/" rel="bookmark" class="td-image-wrap" title="GoL to Launch 4G Data, Voice Services in Remote Parts of Gbarpolu"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="GoL to Launch 4G Data, Voice Services in Remote Parts of Gbarpolu" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/LTA.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/gol-to-launch-4g-data-voice-services-in-remote-parts-of-gbarpolu/" rel="bookmark" title="GoL to Launch 4G Data, Voice Services in Remote Parts of Gbarpolu">GoL to Launch 4G Data, Voice Services in Remote Parts of&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/firestone-to-resume-rubber-purchase-soon/" rel="bookmark" class="td-image-wrap" title="Firestone to Resume Rubber Purchase Soon"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Firestone to Resume Rubber Purchase Soon" data-type="image_tag" data-img-url="https://i1.wp.com/www.liberianobserver.com/wp-content/uploads/2015/04/LACC chairman -e1583593338239.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./columns/agriculture/" class="td-post-category">Agriculture</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/firestone-to-resume-rubber-purchase-soon/" rel="bookmark" title="Firestone to Resume Rubber Purchase Soon">Firestone to Resume Rubber Purchase Soon</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/raw-water-pipeline-construction-more-than-50-complete/" rel="bookmark" class="td-image-wrap" title="Raw Water Pipeline Construction More Than 50% Complete, MCA-L Reports"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Raw Water Pipeline Construction More Than 50% Complete, MCA-L Reports" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Raw-Water-Pipeline_MCA-L.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./business/" class="td-post-category">Business</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/raw-water-pipeline-construction-more-than-50-complete/" rel="bookmark" title="Raw Water Pipeline Construction More Than 50% Complete, MCA-L Reports">Raw Water Pipeline Construction More Than 50% Complete, MCA-L Reports</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/cocoa-exporter-refutes-claims-on-bill-to-amend-lacra/" rel="bookmark" class="td-image-wrap" title="Cocoa Exporter Refutes Claims on Bill to Amend LACRA"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Cocoa Exporter Refutes Claims on Bill to Amend LACRA" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Turays-photo-e1583593234799.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./columns/agriculture/" class="td-post-category">Agriculture</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/cocoa-exporter-refutes-claims-on-bill-to-amend-lacra/" rel="bookmark" title="Cocoa Exporter Refutes Claims on Bill to Amend LACRA">Cocoa Exporter Refutes Claims on Bill to Amend LACRA</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_12_544" data-td_block_id="tdi_12_544"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_12_544" data-td_block_id="tdi_12_544"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-28623"><a href="https://www.liberianobserver.com/./opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_18_f4f td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_18_f4f"><script>var block_tdi_18_f4f = new tdBlock();
block_tdi_18_f4f.id = "tdi_18_f4f";
block_tdi_18_f4f.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"547","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_18_f4f","tdc_css_class":"tdi_18_f4f","tdc_css_class_style":"tdi_18_f4f_rand_style"}';
block_tdi_18_f4f.td_column_number = "3";
block_tdi_18_f4f.block_type = "td_block_mega_menu";
block_tdi_18_f4f.post_count = "4";
block_tdi_18_f4f.found_posts = "3417";
block_tdi_18_f4f.header_color = "";
block_tdi_18_f4f.ajax_pagination_infinite_stop = "";
block_tdi_18_f4f.max_num_pages = "855";
tdBlocksArray.push(block_tdi_18_f4f);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_18_f4f" id="tdi_19_567" data-td_block_id="tdi_18_f4f" data-td_filter_value="" href="https://www.liberianobserver.com/./opinion/">All</a><a class="mega-menu-sub-cat-tdi_18_f4f" id="tdi_20_490" data-td_block_id="tdi_18_f4f" data-td_filter_value="561" href="https://www.liberianobserver.com/./opinion/cartoon/">Cartoon</a><a class="mega-menu-sub-cat-tdi_18_f4f" id="tdi_21_054" data-td_block_id="tdi_18_f4f" data-td_filter_value="550" href="https://www.liberianobserver.com/./opinion/commentaries/">Commentaries</a><a class="mega-menu-sub-cat-tdi_18_f4f" id="tdi_22_5cb" data-td_block_id="tdi_18_f4f" data-td_filter_value="546" href="https://www.liberianobserver.com/./opinion/editorials/">Editorials</a><a class="mega-menu-sub-cat-tdi_18_f4f" id="tdi_23_7b4" data-td_block_id="tdi_18_f4f" data-td_filter_value="549" href="https://www.liberianobserver.com/./opinion/letters/">Letters</a></div></div><div id=tdi_18_f4f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/editorials/stop-using-generators-inside-your-home-if-you-dont-you-and-your-family-will-die/" rel="bookmark" class="td-image-wrap" title="STOP Using Generators inside Your Home: If You Don’t, You and Your Family Will Die!"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/editorials/" class="td-post-category">Editorials</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/editorials/stop-using-generators-inside-your-home-if-you-dont-you-and-your-family-will-die/" rel="bookmark" title="STOP Using Generators inside Your Home: If You Don’t, You and Your Family Will Die!">STOP Using Generators inside Your Home: If You Don’t, You and&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/" rel="bookmark" class="td-image-wrap" title="Zeogar Wilson’s Reckless and Irresponsible Attacks on Nimba County"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/commentaries/" class="td-post-category">Commentaries</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/" rel="bookmark" title="Zeogar Wilson’s Reckless and Irresponsible Attacks on Nimba County">Zeogar Wilson’s Reckless and Irresponsible Attacks on Nimba County</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/editorials/drogba-scores-big-tourism-win-for-cote-divoire-what-does-this-teach-us-about-ourselves-and-our-country/" rel="bookmark" class="td-image-wrap" title="Drogba Scores Big Tourism Win for Cote d’Ivoire: What Does This Teach Us about Ourselves and Our Country?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/editorials/" class="td-post-category">Editorials</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/editorials/drogba-scores-big-tourism-win-for-cote-divoire-what-does-this-teach-us-about-ourselves-and-our-country/" rel="bookmark" title="Drogba Scores Big Tourism Win for Cote d’Ivoire: What Does This Teach Us about Ourselves and Our Country?">Drogba Scores Big Tourism Win for Cote d’Ivoire: What Does This&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/be-a-feminist-demand-that-the-multinationals-pay-their-taxes/" rel="bookmark" class="td-image-wrap" title="Be a Feminist, Demand that the Multinationals Pay Their Taxes!"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/commentaries/" class="td-post-category">Commentaries</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/be-a-feminist-demand-that-the-multinationals-pay-their-taxes/" rel="bookmark" title="Be a Feminist, Demand that the Multinationals Pay Their Taxes!">Be a Feminist, Demand that the Multinationals Pay Their Taxes!</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_18_f4f" data-td_block_id="tdi_18_f4f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_18_f4f" data-td_block_id="tdi_18_f4f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-28628"><a href="https://www.liberianobserver.com/./sports/">Sports</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_24_cce td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_24_cce"><script>var block_tdi_24_cce = new tdBlock();
block_tdi_24_cce.id = "tdi_24_cce";
block_tdi_24_cce.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"545","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_24_cce","tdc_css_class":"tdi_24_cce","tdc_css_class_style":"tdi_24_cce_rand_style"}';
block_tdi_24_cce.td_column_number = "3";
block_tdi_24_cce.block_type = "td_block_mega_menu";
block_tdi_24_cce.post_count = "4";
block_tdi_24_cce.found_posts = "2259";
block_tdi_24_cce.header_color = "";
block_tdi_24_cce.ajax_pagination_infinite_stop = "";
block_tdi_24_cce.max_num_pages = "565";
tdBlocksArray.push(block_tdi_24_cce);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_24_cce" id="tdi_25_605" data-td_block_id="tdi_24_cce" data-td_filter_value="" href="https://www.liberianobserver.com/./sports/">All</a><a class="mega-menu-sub-cat-tdi_24_cce" id="tdi_26_605" data-td_block_id="tdi_24_cce" data-td_filter_value="564" href="https://www.liberianobserver.com/./sports/athlete-profiles/">Athlete Profiles</a><a class="mega-menu-sub-cat-tdi_24_cce" id="tdi_27_450" data-td_block_id="tdi_24_cce" data-td_filter_value="563" href="https://www.liberianobserver.com/./sports/basketball/">Basketball</a><a class="mega-menu-sub-cat-tdi_24_cce" id="tdi_28_576" data-td_block_id="tdi_24_cce" data-td_filter_value="562" href="https://www.liberianobserver.com/./sports/football/">Football</a><a class="mega-menu-sub-cat-tdi_24_cce" id="tdi_29_35c" data-td_block_id="tdi_24_cce" data-td_filter_value="565" href="https://www.liberianobserver.com/./sports/leagues/">Leagues</a><a class="mega-menu-sub-cat-tdi_24_cce" id="tdi_30_4c5" data-td_block_id="tdi_24_cce" data-td_filter_value="566" href="https://www.liberianobserver.com/./sports/sports-administration/">Sports Administration</a><a class="mega-menu-sub-cat-tdi_24_cce" id="tdi_31_755" data-td_block_id="tdi_24_cce" data-td_filter_value="1032" href="https://www.liberianobserver.com/./sports/track-field/">Track &amp; Field</a></div></div><div id=tdi_24_cce class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/liberia-win-3rd-place-in-wafu-womens-tourney-defeat-cape-verde-1-0/" rel="bookmark" class="td-image-wrap" title="Liberia Win 3rd-Place in WAFU Women&#8217;s Tourney, Defeat Cape Verde 1-0"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Liberia Win 3rd-Place in WAFU Women&#8217;s Tourney, Defeat Cape Verde 1-0" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Womens-national-team.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./columns/" class="td-post-category">Columns</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/liberia-win-3rd-place-in-wafu-womens-tourney-defeat-cape-verde-1-0/" rel="bookmark" title="Liberia Win 3rd-Place in WAFU Women&#8217;s Tourney, Defeat Cape Verde 1-0">Liberia Win 3rd-Place in WAFU Women&#8217;s Tourney, Defeat Cape Verde 1-0</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/high-school-tournament-kicks-off-in-ganta/" rel="bookmark" class="td-image-wrap" title="High School Tournament Kicks Off in Ganta"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="High School Tournament Kicks Off in Ganta" data-type="image_tag" data-img-url="https://i1.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/IMG_20200304_173408_6-1.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./sports/football/" class="td-post-category">Football</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/high-school-tournament-kicks-off-in-ganta/" rel="bookmark" title="High School Tournament Kicks Off in Ganta">High School Tournament Kicks Off in Ganta</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/liberian-athlete-wins-nelson-mandela-freedom-award-in-america/" rel="bookmark" class="td-image-wrap" title="Liberian Athlete Wins Nelson Mandela Freedom Award in America"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Liberian Athlete Wins Nelson Mandela Freedom Award in America" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Ambassador-Bill-Rogers.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./sports/athlete-profiles/" class="td-post-category">Athlete Profiles</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/liberian-athlete-wins-nelson-mandela-freedom-award-in-america/" rel="bookmark" title="Liberian Athlete Wins Nelson Mandela Freedom Award in America">Liberian Athlete Wins Nelson Mandela Freedom Award in America</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/wafu-womens-tourney-semifinals-liberia-lose-2-1-to-senegal/" rel="bookmark" class="td-image-wrap" title="WAFU Women’s Tourney Semifinals: Liberia Lose 2-1 to Senegal"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="WAFU Women’s Tourney Semifinals: Liberia Lose 2-1 to Senegal" data-type="image_tag" data-img-url="https://i1.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Liberia-vs-Mali.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./columns/" class="td-post-category">Columns</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/wafu-womens-tourney-semifinals-liberia-lose-2-1-to-senegal/" rel="bookmark" title="WAFU Women’s Tourney Semifinals: Liberia Lose 2-1 to Senegal">WAFU Women’s Tourney Semifinals: Liberia Lose 2-1 to Senegal</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_24_cce" data-td_block_id="tdi_24_cce"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_24_cce" data-td_block_id="tdi_24_cce"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-28590"><a href="https://www.liberianobserver.com/./columns/">Columns</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_32_ff5 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_32_ff5"><script>var block_tdi_32_ff5 = new tdBlock();
block_tdi_32_ff5.id = "tdi_32_ff5";
block_tdi_32_ff5.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"567","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_32_ff5","tdc_css_class":"tdi_32_ff5","tdc_css_class_style":"tdi_32_ff5_rand_style"}';
block_tdi_32_ff5.td_column_number = "3";
block_tdi_32_ff5.block_type = "td_block_mega_menu";
block_tdi_32_ff5.post_count = "4";
block_tdi_32_ff5.found_posts = "6417";
block_tdi_32_ff5.header_color = "";
block_tdi_32_ff5.ajax_pagination_infinite_stop = "";
block_tdi_32_ff5.max_num_pages = "1605";
tdBlocksArray.push(block_tdi_32_ff5);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_32_ff5" id="tdi_33_542" data-td_block_id="tdi_32_ff5" data-td_filter_value="" href="https://www.liberianobserver.com/./columns/">All</a><a class="mega-menu-sub-cat-tdi_32_ff5" id="tdi_34_b46" data-td_block_id="tdi_32_ff5" data-td_filter_value="568" href="https://www.liberianobserver.com/./columns/agriculture/">Agriculture</a><a class="mega-menu-sub-cat-tdi_32_ff5" id="tdi_35_666" data-td_block_id="tdi_32_ff5" data-td_filter_value="569" href="https://www.liberianobserver.com/./columns/education/">Education</a><a class="mega-menu-sub-cat-tdi_32_ff5" id="tdi_36_c74" data-td_block_id="tdi_32_ff5" data-td_filter_value="570" href="https://www.liberianobserver.com/./columns/environment/">Environment</a><a class="mega-menu-sub-cat-tdi_32_ff5" id="tdi_37_605" data-td_block_id="tdi_32_ff5" data-td_filter_value="571" href="https://www.liberianobserver.com/./columns/health/">Health</a><a class="mega-menu-sub-cat-tdi_32_ff5" id="tdi_38_647" data-td_block_id="tdi_32_ff5" data-td_filter_value="581" href="https://www.liberianobserver.com/./columns/religion/">Religion</a><a class="mega-menu-sub-cat-tdi_32_ff5" id="tdi_39_346" data-td_block_id="tdi_32_ff5" data-td_filter_value="572" href="https://www.liberianobserver.com/./columns/technology/">Technology</a><a class="mega-menu-sub-cat-tdi_32_ff5" id="tdi_40_60e" data-td_block_id="tdi_32_ff5" data-td_filter_value="573" href="https://www.liberianobserver.com/./columns/women/">Women</a><a class="mega-menu-sub-cat-tdi_32_ff5" id="tdi_41_8c6" data-td_block_id="tdi_32_ff5" data-td_filter_value="574" href="https://www.liberianobserver.com/./columns/youth/">Youth</a></div></div><div id=tdi_32_ff5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/prez-weah-pledges-support-to-ellen-sirleaf-presidential-center/" rel="bookmark" class="td-image-wrap" title="Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Presidnet-Weah-and-former-President-Sirleaf-at-the-launch-of-her-Amujae-Initiative.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/prez-weah-pledges-support-to-ellen-sirleaf-presidential-center/" rel="bookmark" title="Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center">Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/ganta-tense-over-death-of-motorcyclist/" rel="bookmark" class="td-image-wrap" title="Ganta Tense over Death of Motorcyclist"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Ganta Tense over Death of Motorcyclist" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Police-officers-guard-their-station-in-Ganta-from-stone-throwing-public.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/local/" class="td-post-category">Local</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/ganta-tense-over-death-of-motorcyclist/" rel="bookmark" title="Ganta Tense over Death of Motorcyclist">Ganta Tense over Death of Motorcyclist</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/keep-oxfam-launch-national-transformative-education-initiative/" rel="bookmark" class="td-image-wrap" title="KEEP, Oxfam Launch National &#8216;Transformative Education&#8217; Initiative"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="KEEP, Oxfam Launch National &#8216;Transformative Education&#8217; Initiative" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Authorities-of-KEEP-Oxfam-beneficiares-of-the-project-partners-in-education-and-Mr.-Kerl-posed-shortly-after-the-program..jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/keep-oxfam-launch-national-transformative-education-initiative/" rel="bookmark" title="KEEP, Oxfam Launch National &#8216;Transformative Education&#8217; Initiative">KEEP, Oxfam Launch National &#8216;Transformative Education&#8217; Initiative</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/gol-to-launch-4g-data-voice-services-in-remote-parts-of-gbarpolu/" rel="bookmark" class="td-image-wrap" title="GoL to Launch 4G Data, Voice Services in Remote Parts of Gbarpolu"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="GoL to Launch 4G Data, Voice Services in Remote Parts of Gbarpolu" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/LTA.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/gol-to-launch-4g-data-voice-services-in-remote-parts-of-gbarpolu/" rel="bookmark" title="GoL to Launch 4G Data, Voice Services in Remote Parts of Gbarpolu">GoL to Launch 4G Data, Voice Services in Remote Parts of&#8230;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_32_ff5" data-td_block_id="tdi_32_ff5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_32_ff5" data-td_block_id="tdi_32_ff5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-28604"><a href="https://www.liberianobserver.com/./lib-life/">LIB Life</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_42_420 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_42_420"><script>var block_tdi_42_420 = new tdBlock();
block_tdi_42_420.id = "tdi_42_420";
block_tdi_42_420.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"552","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_42_420","tdc_css_class":"tdi_42_420","tdc_css_class_style":"tdi_42_420_rand_style"}';
block_tdi_42_420.td_column_number = "3";
block_tdi_42_420.block_type = "td_block_mega_menu";
block_tdi_42_420.post_count = "4";
block_tdi_42_420.found_posts = "2154";
block_tdi_42_420.header_color = "";
block_tdi_42_420.ajax_pagination_infinite_stop = "";
block_tdi_42_420.max_num_pages = "539";
tdBlocksArray.push(block_tdi_42_420);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_42_420" id="tdi_43_653" data-td_block_id="tdi_42_420" data-td_filter_value="" href="https://www.liberianobserver.com/./lib-life/">All</a><a class="mega-menu-sub-cat-tdi_42_420" id="tdi_44_455" data-td_block_id="tdi_42_420" data-td_filter_value="575" href="https://www.liberianobserver.com/./lib-life/arts/">Arts</a><a class="mega-menu-sub-cat-tdi_42_420" id="tdi_45_a76" data-td_block_id="tdi_42_420" data-td_filter_value="580" href="https://www.liberianobserver.com/./lib-life/entertainment/">Entertainment</a><a class="mega-menu-sub-cat-tdi_42_420" id="tdi_46_067" data-td_block_id="tdi_42_420" data-td_filter_value="582" href="https://www.liberianobserver.com/./lib-life/history-us/">History &amp; Us</a><a class="mega-menu-sub-cat-tdi_42_420" id="tdi_47_73c" data-td_block_id="tdi_42_420" data-td_filter_value="839" href="https://www.liberianobserver.com/./lib-life/people/">People</a><a class="mega-menu-sub-cat-tdi_42_420" id="tdi_48_437" data-td_block_id="tdi_42_420" data-td_filter_value="578" href="https://www.liberianobserver.com/./lib-life/poetry/">Poetry</a><a class="mega-menu-sub-cat-tdi_42_420" id="tdi_49_80e" data-td_block_id="tdi_42_420" data-td_filter_value="577" href="https://www.liberianobserver.com/./lib-life/short-story/">Short Story</a><a class="mega-menu-sub-cat-tdi_42_420" id="tdi_50_5e7" data-td_block_id="tdi_42_420" data-td_filter_value="576" href="https://www.liberianobserver.com/./lib-life/style/">Style</a><a class="mega-menu-sub-cat-tdi_42_420" id="tdi_51_864" data-td_block_id="tdi_42_420" data-td_filter_value="579" href="https://www.liberianobserver.com/./lib-life/travel/">Travel</a></div></div><div id=tdi_42_420 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/memorial-to-late-gen-thomas-g-quiwonkpa-under-construction-in-ganta/" rel="bookmark" class="td-image-wrap" title="Memorial to Late Gen. Thomas G. Quiwonkpa Under Construction in Ganta"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Memorial to Late Gen. Thomas G. Quiwonkpa Under Construction in Ganta" data-type="image_tag" data-img-url="https://i1.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Monument-to-Quiwonkpa.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./lib-life/arts/" class="td-post-category">Arts</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/memorial-to-late-gen-thomas-g-quiwonkpa-under-construction-in-ganta/" rel="bookmark" title="Memorial to Late Gen. Thomas G. Quiwonkpa Under Construction in Ganta">Memorial to Late Gen. Thomas G. Quiwonkpa Under Construction in Ganta</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/fuamah-cultural-festival-gains-traction/" rel="bookmark" class="td-image-wrap" title="Fuamah Cultural Festival Gains Traction"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Fuamah Cultural Festival Gains Traction" data-type="image_tag" data-img-url="https://i1.wp.com/www.liberianobserver.com/wp-content/uploads/2020/01/vlcsnap-2020-01-29-21h36m56s14-.png?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/fuamah-cultural-festival-gains-traction/" rel="bookmark" title="Fuamah Cultural Festival Gains Traction">Fuamah Cultural Festival Gains Traction</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/govt-prepares-for-miss-liberia-pageant/" rel="bookmark" class="td-image-wrap" title="Gov’t Prepares for Miss Liberia Pageant"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Gov’t Prepares for Miss Liberia Pageant" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2020/02/index.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/govt-prepares-for-miss-liberia-pageant/" rel="bookmark" title="Gov’t Prepares for Miss Liberia Pageant">Gov’t Prepares for Miss Liberia Pageant</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/vp-howard-taylor-reiterates-governments-support-to-people-with-disabilities/" rel="bookmark" class="td-image-wrap" title="VP Taylor Promises  Government’s Protection of People With Disabilities"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="VP Taylor Promises  Government’s Protection of People With Disabilities" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Howard-Taylor.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/vp-howard-taylor-reiterates-governments-support-to-people-with-disabilities/" rel="bookmark" title="VP Taylor Promises  Government’s Protection of People With Disabilities">VP Taylor Promises Government’s Protection of People With Disabilities</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_42_420" data-td_block_id="tdi_42_420"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_42_420" data-td_block_id="tdi_42_420"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-28622"><a href="https://www.liberianobserver.com/./obituaries/">Obituaries</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-78579"><a href="https://www.liberianobserver.com/dev-matters/">Dev Matters</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-50465"><a href="http://liberiapromisetracker.com/">Election Promises</a></li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.liberianobserver.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-1 ">
<div class="td-crumb-container"></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-145897" class="post-145897 post type-post status-publish format-standard category-commentaries category-opinion" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="https://www.liberianobserver.com/./opinion/">Opinion</a></li><li class="entry-category"><a href="https://www.liberianobserver.com/./opinion/commentaries/">Commentaries</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">Zeogar Wilson’s Reckless and Irresponsible Attacks on Nimba County</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.liberianobserver.com/author/jmsendolo/">Joaquin M. Sendolo</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-10T02:16:00+00:00">March 10, 2020</time></span> <div class="td-post-comments"><a href="https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/#comments"><i class="td-icon-comments"></i>1</a></div> <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-145897">26</span></div> </div>
</header>
</div>
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Fzeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Zeogar+Wilson%E2%80%99s+Reckless+and+Irresponsible+Attacks+on+Nimba+County&url=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Fzeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county%2F&via=Libobserver">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/&amp;media=&description=Zeogar+Wilson%E2%80%99s+Reckless+and+Irresponsible+Attacks+on+Nimba+County">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Zeogar+Wilson%E2%80%99s+Reckless+and+Irresponsible+Attacks+on+Nimba+County %0A%0A https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content">
<div class="td-featured-image-rec">

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-post_style_1 tdi_52_f0f td_block_template_1 ">
<style>
/* custom css */
.tdi_52_f0f.td-a-rec-img{
text-align: left;
}.tdi_52_f0f.td-a-rec-img img{
margin: 0 auto 0 0;
}
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;
if ( td_screen_width >= 1140 ) {
/* large monitors */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2114884118"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
/* landscape tablets */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2114884118"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
/* portrait tablets */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2114884118"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width < 768 ) {
/* Phones */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2114884118"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>

</div>
<h2><em><strong>A Nimba Citizen’s Response &#8212; Part One</strong></em></h2>
<p><em><strong>By Kadiker Rex Dahn, MA, M.Ed, PhD</strong></em></p>
<p><strong>Background</strong></p>
<p>Certainly, there are individuals in the George Weah’s led government who relentlessly continue to make derogatory, reckless and irresponsible statements against others. One does not need to be a rocket scientist to ascertain such fact. Periodic verbal attacks against citizens from the headquarters of the CDC are songs on Liberian radios and social media. The Ministry of Information seems also to be deficient and disoriented in defending the government as often, it is found to be reckless and irresponsible in some of its opinions. It is alleged that almost all who claim to speak in the name of CDC may have a twisted mind, thinking and illogical analysis. Case in point, Zeogar Wilson, the Minister of Youth and Sports outlandish attack against the people of Nimba County speaks to the fact that George Weah’s led government is infested with individuals who are reckless and irresponsible in their utterances. The purpose of this article is twofold: first, debunk Zeogar Wilson’s claims of hooliganism against Nimba County and second, argues that Zeogar’s statement was reckless and irresponsible of a government’s minister.</p>
<p><strong>Discussions</strong></p>
<p>In the just ended County Meet which ended in stalemate as a result of criminality on the part of the umpire, Zeogar Wilson, the Minister of Youth and Sports accused the people of Nimba County of being hooligans. What Nimba County did on the field of play to warrant such charge is yet to be soundly, reasonably and logically explained. The charge in question without evidence clearly indicates the unsophistication, naivety and ineptitude of Minister Wilson. The fact of the matter was that Team Nimba realized that the direction the game was unfolding was unfair and if continued on the field of play, might end in confusion. In avoiding such perceived confusion, the Team and its officials decided to leave the field. Impartial and sound Liberians on the field that day are witnesses to Nimba County’s decision. Not a single Nimba County’s player or official engaged in any form of vandalism; Nimba County’s players and coaches peacefully and quietly left the field. The Minister of Youth and Sports, Zeogar Wilson with concealed notion and prejudice described the people of Nimba County as hooligans. Whether Zeogar fully understood the meaning of hooligans is yet to be determined. Be as it may, it seems to us that Minister Zeogar Wilson during the press conference in which he described the people of Nimba County as hooligans might not have been in the right state of mind. The Minister’s abrupt unbecoming action against Nimba County without any evidence of vandalism compelled me to questions the state of mind of Zeogar Wilson: we ask, was the minister under the influence of a narcotic substance? Are there records of illegal drug use? Was he inebriated? Has he ever been diagnosed with any form of mental disorder? Is he on any medication to enable him function properly without which he becomes disoriented, incoherent, hallucinated and paranoia? We asked these questions because no one in their right state of mind will attack a peaceful, generous and loving people like Nimba County without tangible evidence. Something is intellectually wrong with Zeogar Wilson’s comprehension and analysis.</p>
<p><strong>Zeogar’s confused and convoluted response</strong></p>
<p>When Zeogar Wilson described the people of Nimba County as hooligans and seeing the level of criticisms against him, he summersaulted and denied ever addressing the people of Nimba County as hooligans. In his distorted, confused, convoluted, elementary and twisted response, Zeogar claimed that the reference made with respect to hooliganism was mainly directed at the players and coaches of Nimba County and not the entire County. Here again, the unsophistication, naivety and ineptitude of the Minister in question is clearly seen. Claiming that he was referring to players and coaches and not the County as a whole is one of the worst, confused and half-baked explanations I have ever seen and heard. We maintain: Zeogar Wilson, you are damn wrong and your explanation is imbued with serious limitations, flaws and fallacies.</p>
<p>Remember this: those players and coaches in question are citizens of Nimba County and hired by the people of Nimba County to represent the County during the County Meet. During the tournament, whenever players and coaches appeared, they did so under the flag of Nimba County. In other words, they were Nimba County’s representatives in every aspect of the game. In this sense, whatever happens to them whether good or bad under that Nimba County’s flag happens to the entire County. Therefore, it seems, sounds nonsensical and absurd to deny the claim of Nimba County being attacked. Zeogar Wilson’s action against Nimba County and George Weah’s silence does not speak well of George Weah and his government. We made these claims for two reasons: Zeogar Wilson as a minister of Youth and sports has set an ugly precedent to the young people of Liberia. We expect a minister of youth and sports who is responsible for the all the young people in this Republic to be a person of a good moral character. Such minister’s word should be descent and uplifting and if on the other hand, it turns out to be unbecoming, it brings cultural miseducation, shame and ignominy to such an entity. This is the case with Zeogar Wilson as a minister of Youth and Sports. Under the doctrine of reciprocation, our people could have equally lavished insults on him; we refused because our good characters dictate and deter us from doing so. In the words of former Vice President Boakai, “because of mosquitos, one cannot burn his own house.” In the same way, because of Zeogar’s reckless, irresponsible and uniformed utterance against the people of Nimba County cannot push us against our will to violate our own ethics. We simply say his statement against Nimba County was reckless, irresponsible, uninformed, a shame and a disgrace as a government minister. We condemn it in the highest term possible.</p>
<p>We surmise Zeogar Wilson may have something under his sleeves against Nimba County. Here again, Zeogar who was once a goalie, not even a good goalie compare to legend Peewu Bestman, we thought may still have ideas on the game. Here again is another blunder by Zeogar. Our Coach, though worked for Nimba County during the County Meet, works directly under the LFA and by extension, FiFA. This old footballer suspended the Coach for two years without the acquiescence of LFA and FIFA. Even if LFA is influenced to uphold Zeogar’s decision against the Coach because of government’s intrusion, FIFA as an independent, and trusted international Body, will ensure justice. Since the County Meet is under the supervision of the Ministries of Youth and Sports and Internal Affairs, though illegitimate, their decisions should have remained in the confine of the County Meet and not beyond. LFA and FIFA are different terrains. In fullness of time, FIFA will address the issue of the suspension. Zeogar’s action reminds me of George Weah’s continuous violations of established laws and protocols.</p>
<p><strong>George Weah’s silence</strong></p>
<p>Another fact that we find quite disturbing is the silence of George Weah. George Weah as we all know often complains of being insulted either on radio or on the social media. Some of us, though, disagree with the form and manner in which he governs as a president, oppose the President of a nation from being directly or indirectly insulted. We are taken aback for George Weah to remain mute when his appointee publicly insulted and attacked the people of Nimba County. We surmise that the silence of George Weah is an indication of his approbation. His silence may equally be a direct or indirect invitation to provoke the people of Nimba County. It is alleged that on the order of President Weah, the Mask Dancer and officials of Nimba County were denied from entering a particular gate yet allowed Grand Kru Team to pass such entrance. It was after Grand Kru has passed the gate in question, that Nimba’s mask dancer and officials were allowed to pass. We say to George Weah and his surrogates: do not mess with Nimba County.</p>
<p><strong>Conclusion</strong></p>
<p>We condemn in the highest terms Zeogar Wilson’s attacks on Nimba County. We conclude that the form and manner the final between Nimba and Grand Kru was conducted was indicative of the failure of George weah’s administration. The County Meet is intended to unite the Country. From all indications, the spirit and intent of the County Meet were defeated when George Weah and his surrogates failed to demonstrate real sportsmanship. This is the first time in the history of the County Meet where the leadership of the Country miserably failed. Be as it may, Zeogar Wilson’s attack on Nimba County together with George Weah’s silence to correct the wrong, clearly speaks to the fact that this George Weah may have something under his sleeves against the people of Nimba County. This is a lesson for the people of Nimba County to be cognizant of transactional politicians because it was through transactional politics that Prince Johnson sold George Weah to the people of Nimba County.We expect our elected leaders to address the action of Zeogar against the people of Nimba. In the cause of the People, the Struggle Continues!!!</p>
<p><strong>About the author:</strong> Kadiker Rex Dahn holds a PhD in Historical, Philosophical and Social Foundations of Education from the University of Oklahoma. He once served as a Deputy Minister of Education and Deputy Director General, National Commission on Higher Education. He is a member of the North America Scholar Consortium, Membership with the Highest Honor. Contact: <a href="/cdn-cgi/l/email-protection#c7bea2a9b7b2b287bea6afa8a8e9a4a8aa"><span class="__cf_email__" data-cfemail="1e677b706e6b6b5e677f767171307d7173">[email&#160;protected]</span></a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-145897" class="share-twitter sd-button share-icon no-text" href="https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-145897" class="share-facebook sd-button share-icon no-text" href="https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_bottom tdi_53_e6b td_block_template_1 ">
<style>
/* custom css */
.tdi_53_e6b.td-a-rec-img{
text-align: left;
}.tdi_53_e6b.td-a-rec-img img{
margin: 0 auto 0 0;
}
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;
if ( td_screen_width >= 1140 ) {
/* large monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="6940868918"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
/* landscape tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="6940868918"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
/* portrait tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="6940868918"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width < 768 ) {
/* Phones */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="6940868918"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>

</div>
<footer>
<div class="td-post-source-tags">
</div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Fzeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Zeogar+Wilson%E2%80%99s+Reckless+and+Irresponsible+Attacks+on+Nimba+County&url=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Fzeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county%2F&via=Libobserver">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/&amp;media=&description=Zeogar+Wilson%E2%80%99s+Reckless+and+Irresponsible+Attacks+on+Nimba+County">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Zeogar+Wilson%E2%80%99s+Reckless+and+Irresponsible+Attacks+on+Nimba+County %0A%0A https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.liberianobserver.com/news/liberia-win-3rd-place-in-wafu-womens-tourney-defeat-cape-verde-1-0/">Liberia Win 3rd-Place in WAFU Women&#8217;s Tourney, Defeat Cape Verde 1-0</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://www.liberianobserver.com/opinion/editorials/stop-using-generators-inside-your-home-if-you-dont-you-and-your-family-will-die/">STOP Using Generators inside Your Home: If You Don’t, You and Your Family Will Die!</a></div></div></div> <div class="author-box-wrap"><a href="https://www.liberianobserver.com/author/jmsendolo/"><img alt src="https://secure.gravatar.com/avatar/660706d8a689488806433309f87101cd?s=96&#038;d=mm&#038;r=g" class="avatar avatar-96 photo jetpack-lazy-image" height="96" width="96" data-lazy-srcset="https://secure.gravatar.com/avatar/660706d8a689488806433309f87101cd?s=192&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/660706d8a689488806433309f87101cd?s=96&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/660706d8a689488806433309f87101cd?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/660706d8a689488806433309f87101cd?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></noscript></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.liberianobserver.com/author/jmsendolo/">Joaquin M. Sendolo</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Joaquin M. Sendolo"></span><meta itemprop="datePublished" content="2020-03-10T02:16:00+00:00"><meta itemprop="dateModified" content="2020-03-10T01:14:46+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png"></span><meta itemprop="name" content="Liberian Observer"></span><meta itemprop="headline " content="Zeogar Wilson’s Reckless and Irresponsible Attacks on Nimba County"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.liberianobserver.com/wp-content/themes/Newspaper/images/no-thumb/td_meta_replacement.png"><meta itemprop="width" content="1068"><meta itemprop="height" content="580"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts tdi_54_dae td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_54_dae"><script>var block_tdi_54_dae = new tdBlock();
block_tdi_54_dae.id = "tdi_54_dae";
block_tdi_54_dae.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_54_dae","td_column_number":3,"live_filter_cur_post_id":145897,"live_filter_cur_post_author":"20","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_54_dae","tdc_css_class_style":"tdi_54_dae_rand_style"}';
block_tdi_54_dae.td_column_number = "3";
block_tdi_54_dae.block_type = "td_block_related_posts";
block_tdi_54_dae.post_count = "3";
block_tdi_54_dae.found_posts = "1181";
block_tdi_54_dae.header_color = "";
block_tdi_54_dae.ajax_pagination_infinite_stop = "";
block_tdi_54_dae.max_num_pages = "394";
tdBlocksArray.push(block_tdi_54_dae);
</script><h4 class="td-related-title td-block-title"><a id="tdi_55_666" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_54_dae" href="#">RELATED ARTICLES</a><a id="tdi_56_6e4" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_54_dae" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_54_dae class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/be-a-feminist-demand-that-the-multinationals-pay-their-taxes/" rel="bookmark" class="td-image-wrap" title="Be a Feminist, Demand that the Multinationals Pay Their Taxes!"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/commentaries/" class="td-post-category">Commentaries</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/be-a-feminist-demand-that-the-multinationals-pay-their-taxes/" rel="bookmark" title="Be a Feminist, Demand that the Multinationals Pay Their Taxes!">Be a Feminist, Demand that the Multinationals Pay Their Taxes!</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/shortage-of-gas-an-opportunity-or-disadvantage-to-liberia/" rel="bookmark" class="td-image-wrap" title="“Shortage of Gas an Opportunity or Disadvantage to Liberia?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/commentaries/" class="td-post-category">Commentaries</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/shortage-of-gas-an-opportunity-or-disadvantage-to-liberia/" rel="bookmark" title="“Shortage of Gas an Opportunity or Disadvantage to Liberia?">“Shortage of Gas an Opportunity or Disadvantage to Liberia?</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/2020-a-pivotal-year-for-relations-between-europe-and-africa/" rel="bookmark" class="td-image-wrap" title="&#8220;2020, A Pivotal Year for Relations between Europe and Africa&#8221;"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="&#8220;2020, A Pivotal Year for Relations between Europe and Africa&#8221;" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/EU.jpg?resize=218%2C150&ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/commentaries/" class="td-post-category">Commentaries</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/2020-a-pivotal-year-for-relations-between-europe-and-africa/" rel="bookmark" title="&#8220;2020, A Pivotal Year for Relations between Europe and Africa&#8221;">&#8220;2020, A Pivotal Year for Relations between Europe and Africa&#8221;</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_54_dae" data-td_block_id="tdi_54_dae"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_54_dae" data-td_block_id="tdi_54_dae"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div class="comments" id="comments">
<div class="td-comments-title-wrap td_block_template_1">
<h4 class="td-comments-title block-title"><span>1 COMMENT</span></h4>
</div>
<ol class="comment-list ">
<li class="comment " id="comment-94463">
<article>
<footer>
<img alt src="https://secure.gravatar.com/avatar/71d46add94bca29ca58f5007cbb743cd?s=50&#038;d=mm&#038;r=g" class="avatar avatar-50 photo jetpack-lazy-image" height="50" width="50" data-lazy-srcset="https://secure.gravatar.com/avatar/71d46add94bca29ca58f5007cbb743cd?s=100&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/71d46add94bca29ca58f5007cbb743cd?s=50&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/71d46add94bca29ca58f5007cbb743cd?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/71d46add94bca29ca58f5007cbb743cd?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /></noscript> <cite>CHARLES JOHNSON</cite>
<a class="comment-link" href="#comment-94463">
<time pubdate="1583827864">
March 10, 2020 At 8:11 am</time>
</a>
</footer>
<div class="comment-content tagdiv-type">
<p>THIS TRASH IS YET ANOTHER ORCHESTRATED CAMPAIGN TO POLITICIZE FOOTBALL IN LIBERIA SIMILAR TO HOW BACCUS MATHEWS, OSCAR UIAH, MARCUS DAHN AND CHEA CHEAPOO PERPETRATED THE RICE RIOT THAT RESULTED IN THE WANTON DESTRUCTION OF INFRASTRUCTURE AND HUMAN LIVES IN 1979! THE LIKES LIKE REX DAHN CAN ONLY FOOL LIBERIANS ONCE, BUT NOT ALL THE TIME! LIBERIANS BE WARNED &#8211; AND BEWARE OF KADIKER REX DAHN&#8217;S HIDDEN AGENDA OF USING FOOTBALL TO CAMPAIGN FOR HIS SENATORIAL BID FOR NIMBA COUNTY</p>
</div>
<div class="comment-meta" id="comment-94463">
<a rel='nofollow' class='comment-reply-link' href='https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/?replytocom=94463#respond' data-commentid="94463" data-postid="145897" data-belowelement="comment-94463" data-respondelement="respond" aria-label='Reply to CHARLES JOHNSON'>Reply</a> </div>
</article>
</li>
</ol>
<div class="comment-pagination">
</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=125373089&#038;postid=145897&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=7.9.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=d6bd322827d1ca7d464bfc6611b92942f8235cb4#parent=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Fzeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
<!--[if !IE]><!-->
<script>
document.addEventListener('DOMContentLoaded', function () {
var commentForms = document.getElementsByClassName('jetpack_remote_comment');
for (var i = 0; i < commentForms.length; i++) {
commentForms[i].allowTransparency = false;
commentForms[i].scrolling = 'no';
}
});
</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div data-embed="widget"><script type="text/props">{"action":"add-to-cart","colors":{"buttons":{"background":"#7959c7","text":"#ffffff"},"checkout":{"background":"#7959c7","text":"#ffffff"}},"description":true,"logos":true,"modal":true,"text":"Add to cart","url":"https://selz.co/NkeHswVtU","width":400}</script></div>
<script async src="https://embeds.selzstatic.com/1/loader.js"></script>
<noscript><a href="https://selz.co/NkeHswVtU" target="_blank" rel="noopener noreferrer">Add to cart</a></noscript></div></aside>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar tdi_57_c41 td_block_template_1 ">
<style>
/* custom css */
.tdi_57_c41.td-a-rec-img{
text-align: left;
}.tdi_57_c41.td-a-rec-img img{
margin: 0 auto 0 0;
}
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;
if ( td_screen_width >= 1140 ) {
/* large monitors */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2510669317"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
/* landscape tablets */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2510669317"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
/* portrait tablets */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2510669317"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width < 768 ) {
/* Phones */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2510669317"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>

<aside class="widget_text td_block_template_1 widget widget_custom_html"><h4 class="block-title"><span>Related News</span></h4><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-6475113583811280" data-ad-slot="5555173659"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside class="td_block_template_1 widget widget_recent_comments"><h4 class="block-title"><span>Join the Conversation</span></h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">CHARLES JOHNSON</span> on <a href="https://www.liberianobserver.com/opinion/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county/#comment-94463">Zeogar Wilson’s Reckless and Irresponsible Attacks on Nimba County</a></li><li class="recentcomments"><span class="comment-author-link">Joseph M. Akoi</span> on <a href="https://www.liberianobserver.com/news/former-pres-sirleaf-authorized-disbursement-of-afls-pension-money/#comment-94461">‘Former Pres. Sirleaf Authorized Disbursement of AFL’s Pension Money’</a></li><li class="recentcomments"><span class="comment-author-link">Petarus Dolo</span> on <a href="https://www.liberianobserver.com/news/prez-weah-pledges-support-to-ellen-sirleaf-presidential-center/#comment-94460">Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center</a></li><li class="recentcomments"><span class="comment-author-link">Petarus Dolo</span> on <a href="https://www.liberianobserver.com/news/fmr-president-sirleaf-stop-tearing-liberia-apart-it-scares-investors/#comment-94457">“Stop Tearing Liberia Apart; It Scares Investors”</a></li><li class="recentcomments"><span class="comment-author-link">MONUMENT TO A WAR CRIMES KILLER AND MURDERER WHAT THE HELL WRONG WITH LIBERIA</span> on <a href="https://www.liberianobserver.com/news/memorial-to-late-gen-thomas-g-quiwonkpa-under-construction-in-ganta/#comment-94456">Memorial to Late Gen. Thomas G. Quiwonkpa Under Construction in Ganta</a></li><li class="recentcomments"><span class="comment-author-link">joe Moses</span> on <a href="https://www.liberianobserver.com/news/firestone-to-resume-rubber-purchase-soon/#comment-94455">Firestone to Resume Rubber Purchase Soon</a></li><li class="recentcomments"><span class="comment-author-link">joe Moses</span> on <a href="https://www.liberianobserver.com/news/firestone-to-resume-rubber-purchase-soon/#comment-94454">Firestone to Resume Rubber Purchase Soon</a></li><li class="recentcomments"><span class="comment-author-link">Anthony Swen</span> on <a href="https://www.liberianobserver.com/news/firestone-to-resume-rubber-purchase-soon/#comment-94453">Firestone to Resume Rubber Purchase Soon</a></li><li class="recentcomments"><span class="comment-author-link">Renford Walsh</span> on <a href="https://www.liberianobserver.com/news/fmr-president-sirleaf-stop-tearing-liberia-apart-it-scares-investors/#comment-94452">“Stop Tearing Liberia Apart; It Scares Investors”</a></li><li class="recentcomments"><span class="comment-author-link">kae</span> on <a href="https://www.liberianobserver.com/news/we-must-not-allow-our-focus-to-be-distracted/#comment-94451">&#8216;We Must Not Allow Our Focus To Be Distracted&#8217;</a></li></ul></aside> </div>
</div>
</div> 
</div> 
</div> 


<div class="td-footer-wrapper td-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span8">
</div>
<div class="td-pb-span4">
</div>
</div>
</div>
<div class="td-footer-bottom-full">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.liberianobserver.com/"><img class="td-retina-data" src="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" data-retina="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" alt="Daily Observer Logo" title="Daily Observer" width="" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Liberianobserver.com is the online version of its print edition, the Daily Observer newspaper, a product of the Liberian Observer Corporation. The Daily Observer publishes a wide range of content including politics, business, sports and entertainment on and about Liberia. Follow us on social media for all the latest news and analysis. <div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#caa6a3a8afb8a3aba4a5a8b9afb8bcafb88aada7aba3a6e4a9a5a7"><span class="__cf_email__" data-cfemail="fe92979c9b8c979f90919c8d9b8c889b8cbe99939f9792d09d9193">[email&#160;protected]</span></a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/pages/Liberian-Observer-Online/42279623238" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/libobserver/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.titter.com/libobserver" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/locmultimedia" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span></aside></div> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="td-subfooter-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-28852"><a href="https://www.scribd.com/Liberian%20Daily%20Observer">E-Edition</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-28964"><a href="https://www.liberianobserver.com/wp-login.php">Login</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home td-menu-item td-normal-menu menu-item-28965"><a href="https://www.liberianobserver.com">Advertisements</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home td-menu-item td-normal-menu menu-item-28966"><a href="https://www.liberianobserver.com">Archives</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-69499"><a href="https://www.liberianobserver.com/opportunities/">Opportunities</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
&copy; Liberian Observer Corporation </div>
</div>
</div>
</div>
</div>
<div style="display:none">
<div class="grofile-hash-map-660706d8a689488806433309f87101cd">
</div>
<div class="grofile-hash-map-71d46add94bca29ca58f5007cbb743cd">
</div>
</div>
<div class="td-more-articles-box">
<i class="td-icon-close td-close-more-articles-box"></i>
<span class="td-more-articles-box-title">MORE STORIES</span>
<div class="td-content-more-articles-box">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/dont-kill-senator-dillons-brother-without-giving-him-due-processes/" rel="bookmark" class="td-image-wrap" title="‘Don’t Kill Senator Dillon’s Brother Without Giving Him Due Processes’"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="‘Don’t Kill Senator Dillon’s Brother Without Giving Him Due Processes’" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Cllr.-Toe.jpg?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/dont-kill-senator-dillons-brother-without-giving-him-due-processes/" rel="bookmark" title="‘Don’t Kill Senator Dillon’s Brother Without Giving Him Due Processes’">‘Don’t Kill Senator Dillon’s Brother Without Giving Him Due Processes’</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-10T02:30:00+00:00">March 10, 2020</time></span> </div>
</div>
</div>
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/prez-weah-pledges-support-to-ellen-sirleaf-presidential-center/" rel="bookmark" class="td-image-wrap" title="Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2020/03/Presidnet-Weah-and-former-President-Sirleaf-at-the-launch-of-her-Amujae-Initiative.jpg?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/prez-weah-pledges-support-to-ellen-sirleaf-presidential-center/" rel="bookmark" title="Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center">Prez. Weah Pledges Support to Ellen Sirleaf Presidential Center</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-10T02:29:19+00:00">March 10, 2020</time></span> </div>
</div>
</div>
</div>
</div>


<style type="text/css" media="screen">
/* custom css theme panel */
.block-title{border-color: #4db2ec !important;
}
.block-title > span {background-color: #4db2ec !important;}
</style>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
window.WPCOM_sharing_counts = {"https:\/\/www.liberianobserver.com\/opinion\/zeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county\/":145897};
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.9.1/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/bootstrap-modals/js/bootstrap.min.js?ver=3.3.7'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/jquery/ui/datepicker.min.js'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202011'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var superpwa_sw = {"url":"\/OneSignalSDKWorker.js.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/super-progressive-web-apps/public/js/register-sw.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Maraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.9.1/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=c8cba5620a72d5b299fa8f62aeca6adfx'></script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.2'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.9.1/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=13.1.2.4'></script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=c8cba5620a72d5b299fa8f62aeca6adfx'></script>
<script async="async" type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.9.1/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
// If there's another sharing window open, close it.
if ( 'undefined' !== typeof windowOpen ) {
windowOpen.close();
}
windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
return false;
});
var windowOpen;
jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
// If there's another sharing window open, close it.
if ( 'undefined' !== typeof windowOpen ) {
windowOpen.close();
}
windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
return false;
});
</script>

<style type="text/css">
.su-spoiler-style-fancy>.su-spoiler-content{ display: flex;}
</style>


<script>
</script>

<style>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</style>
<!--[if IE]>
<script type="text/javascript">
if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
// window.location.reload() doesn't respect the Hash in IE
window.location.hash = window.location.hash;
}
</script>
<![endif]-->
<script type="text/javascript">
(function () {
var comm_par_el = document.getElementById( 'comment_parent' ),
comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
frame = document.getElementById( 'jetpack_remote_comment' ),
tellFrameNewParent;
tellFrameNewParent = function () {
if ( comm_par ) {
frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=125373089&postid=145897&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=d6bd322827d1ca7d464bfc6611b92942f8235cb4#parent=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Fzeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
} else {
frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=125373089&postid=145897&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=d6bd322827d1ca7d464bfc6611b92942f8235cb4#parent=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Fzeogar-wilsons-reckless-and-irresponsible-attacks-on-nimba-county%2F";
}
};
if ( 'undefined' !== typeof addComment ) {
addComment._Jetpack_moveForm = addComment.moveForm;
addComment.moveForm = function ( commId, parentId, respondId, postId ) {
var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
cancelClick, cancel;
if ( false === returnValue ) {
cancel = document.getElementById( 'cancel-comment-reply-link' );
cancelClick = cancel.onclick;
cancel.onclick = function () {
var cancelReturn = cancelClick.call( this );
if ( false !== cancelReturn ) {
return cancelReturn;
}
if ( ! comm_par ) {
return cancelReturn;
}
comm_par = 0;
tellFrameNewParent();
return cancelReturn;
};
}
if ( comm_par == parentId ) {
return returnValue;
}
comm_par = parentId;
tellFrameNewParent();
return returnValue;
};
}
// Do the post message bit after the dom has loaded.
document.addEventListener( 'DOMContentLoaded', function () {
var iframe_url = "https:\/\/jetpack.wordpress.com";
if ( window.postMessage ) {
if ( document.addEventListener ) {
window.addEventListener( 'message', function ( event ) {
var origin = event.origin.replace( /^http:\/\//i, 'https://' );
if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
return;
}
jQuery( frame ).height( event.data );
});
} else if ( document.attachEvent ) {
window.attachEvent( 'message', function ( event ) {
var origin = event.origin.replace( /^http:\/\//i, 'https://' );
if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
return;
}
jQuery( frame ).height( event.data );
});
}
}
})
})();
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202011.js' async='async' defer='defer'></script>
<script type='text/javascript'>
_stq = window._stq || [];
_stq.push([ 'view', {v:'ext',j:'1:7.9.1',blog:'125373089',post:'145897',tz:'0',srv:'www.liberianobserver.com'} ]);
_stq.push([ 'clickTrackerInit', '125373089', '145897' ]);
</script>
</body>
</html>