<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Let Not the Baghdad Bobs Ask For Whom the Bells Toll! | Liberian Observer</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://www.liberianobserver.com/xmlrpc.php" />

<link rel="manifest" href="/superpwa-manifest.json">
<meta name="theme-color" content="#D5E0EB">
<link rel="apple-touch-icon" sizes="192x192" href="https://www.liberianobserver.com/wp-content/uploads/2018/12/libobserver-icon.png">
<link rel="apple-touch-icon" sizes="512x512" href="https://www.liberianobserver.com/wp-content/uploads/2018/12/libobserver-splashscreen.jpg">

<style>
/* Custom BSA_PRO Styles */
/* fonts */
/* form */
.bsaProOrderingForm {   }
.bsaProInput input,
.bsaProInput input[type='file'],
.bsaProSelectSpace select,
.bsaProInputsRight .bsaInputInner,
.bsaProInputsRight .bsaInputInner label {   }
.bsaProPrice  {  }
.bsaProDiscount  {   }
.bsaProOrderingForm .bsaProSubmit,
.bsaProOrderingForm .bsaProSubmit:hover,
.bsaProOrderingForm .bsaProSubmit:active {   }
/* alerts */
.bsaProAlert,
.bsaProAlert > a,
.bsaProAlert > a:hover,
.bsaProAlert > a:focus {  }
.bsaProAlertSuccess {  }
.bsaProAlertFailed {  }
/* stats */
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-bar,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-line,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-point,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-slice.ct-donut { stroke: #673AB7 !important; }
.bsaStatsWrapper  .ct-chart .ct-series.ct-series-a .ct-bar,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-line,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-point,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-slice.ct-donut { stroke: #FBCD39 !important; }
/* Custom CSS */
</style><link rel="icon" type="image/png" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://liberianobserver.com/wp-content/uploads/2017/03/O-thumbnail-293x300.png" /><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Liberian Observer &raquo; Feed" href="https://www.liberianobserver.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Liberian Observer &raquo; Comments Feed" href="https://www.liberianobserver.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Liberian Observer &raquo; Let Not the Baghdad Bobs Ask For Whom the Bells Toll! Comments Feed" href="https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.liberianobserver.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3"}};
!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
display: inline !important;
border: none !important;
box-shadow: none !important;
height: 1em !important;
width: 1em !important;
margin: 0 .07em !important;
vertical-align: -0.1em !important;
background: none !important;
padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-components-css' href='https://c0.wp.com/c/5.3/wp-includes/css/dist/components/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-font-css' href='https://fonts.googleapis.com/css?family=Noto+Serif%3A400%2C400i%2C700%2C700i&#038;ver=5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-editor-css' href='https://c0.wp.com/c/5.3/wp-includes/css/dist/block-editor/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-nux-css' href='https://c0.wp.com/c/5.3/wp-includes/css/dist/nux/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-css' href='https://c0.wp.com/c/5.3/wp-includes/css/dist/editor/style.min.css' type='text/css' media='all' />












<link rel="stylesheet" type="text/css" href="//www.liberianobserver.com/wp-content/cache/wpfc-minified/qx4iczaf/26xd3.css" media="all" />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;display=swap&#038;ver=10.2' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='vc_lte_ie9-css'  href='https://www.liberianobserver.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.5' type='text/css' media='screen' />
<![endif]-->
<link rel='stylesheet' id='td-theme-css' href='https://www.liberianobserver.com/wp-content/themes/loc-theme/style.css?ver=9.2.2.1547643655' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
@media (max-width: 767px) {
.td-header-desktop-wrap {
display: none;
}
}
@media (min-width: 767px) {
.td-header-mobile-wrap {
display: none;
}
}
</style>

<link rel="stylesheet" type="text/css" href="//www.liberianobserver.com/wp-content/cache/wpfc-minified/fpd10xya/c0iq6.css" media="all" />
<style id='__EPYT__style-inline-css' type='text/css'>
.epyt-gallery-thumb {
width: 33.333%;
}
</style>





<link rel="stylesheet" type="text/css" href="//www.liberianobserver.com/wp-content/cache/wpfc-minified/er1vf2qa/fjcqa.css" media="all" />
<link rel='stylesheet' id='social-logos-css' href='https://c0.wp.com/p/jetpack/7.9.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/7.9.1/css/jetpack.css' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.liberianobserver.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/thickbox/thickbox.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/underscore.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/shortcode.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-admin/js/media-upload.min.js'></script>
<script src='//www.liberianobserver.com/wp-content/cache/wpfc-minified/kc6ufyus/c0iq6.js' type="text/javascript"></script>





<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/www.liberianobserver.com\/wp-admin\/admin-ajax.php","security":"b51738c9fd","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/www.liberianobserver.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/www.liberianobserver.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"13.1.2.4","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script src='//www.liberianobserver.com/wp-content/cache/wpfc-minified/5blhjl3/c0iq6.js' type="text/javascript"></script>

<link rel='https://api.w.org/' href='https://www.liberianobserver.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.liberianobserver.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.liberianobserver.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Major Step toward Green Card, U.S. Citizenship for Liberians on DED' href='https://www.liberianobserver.com/news/major-step-toward-green-card-u-s-citizenship-for-liberians-on-ded/' />
<link rel="canonical" href="https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/" />
<link rel='shortlink' href='https://wp.me/p8u3gB-AhZ' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
window.tdb_globals = {"wpRestNonce":"f34164aa2d","wpRestUrl":"https:\/\/www.liberianobserver.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
</script>
<script>
window.tdwGlobal = {"adminUrl":"https:\/\/www.liberianobserver.com\/wp-admin\/","wpRestNonce":"f34164aa2d","wpRestUrl":"https:\/\/www.liberianobserver.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
</script>
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style> <meta name="onesignal" content="wordpress-plugin" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>
window.OneSignal = window.OneSignal || [];
OneSignal.push( function() {
OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };
OneSignal.setDefaultNotificationUrl("https://www.liberianobserver.com");
var oneSignal_options = {};
window._oneSignalInitOptions = oneSignal_options;
oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '30a33a75-54af-4faf-beb9-c8fced7ae582';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.liberianobserver.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "liberianobserver.com";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'inverse';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['text']['message.prenotify'] = 'Subscribe the latest news stories';
oneSignal_options['notifyButton']['text']['tip.state.subscribed'] = 'You&#039;re subscribed to the latest stories';
OneSignal.init(window._oneSignalInitOptions);
});
function documentInitOneSignal() {
var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");
var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
}
if (document.readyState === 'complete') {
documentInitOneSignal();
}
else {
window.addEventListener("load", function(event){
documentInitOneSignal();
});
}
</script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<style type="text/css">
/* If html does not have either class, do not show lazy loaded images. */
html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
display: none;
}
</style>
<script>
document.documentElement.classList.add(
'jetpack-lazy-images-js-enabled'
);
</script>

<meta property="og:type" content="article" />
<meta property="og:title" content="Let Not the Baghdad Bobs Ask For Whom the Bells Toll!" />
<meta property="og:url" content="https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/" />
<meta property="og:description" content="The drama surrounding the missing billions never seems to end with new twists and turns unfolding by the day. Just a few days ago Presidential Press secretary Solo Kelgbeh had announced to the Libe…" />
<meta property="article:published_time" content="2019-12-16T02:17:00+00:00" />
<meta property="article:modified_time" content="2019-12-14T05:25:58+00:00" />
<meta property="og:site_name" content="Liberian Observer" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />

<meta name="twitter:partner" content="tfwp">

<script>
var tdBlocksArray = []; //here we store all the items for the current page
//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
this.id = '';
this.block_type = 1; //block type id (1-234 etc)
this.atts = '';
this.td_column_number = '';
this.td_current_page = 1; //
this.post_count = 0; //from wp
this.found_posts = 0; //from wp
this.max_num_pages = 0; //from wp
this.td_filter_value = ''; //current live filter value
this.is_ajax_running = false;
this.td_user_action = ''; // load more or infinite loader (used by the animation)
this.header_color = '';
this.ajax_pagination_infinite_stop = ''; //show load more at page x
}
// td_js_generator - mini detector
(function(){
var htmlTag = document.getElementsByTagName("html")[0];
if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
htmlTag.className += ' ie10';
}
if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
htmlTag.className += ' ie11';
}
if ( navigator.userAgent.indexOf("Edge") > -1 ) {
htmlTag.className += ' ieEdge';
}
if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
htmlTag.className += ' td-md-is-ios';
}
var user_agent = navigator.userAgent.toLowerCase();
if ( user_agent.indexOf("android") > -1 ) {
htmlTag.className += ' td-md-is-android';
}
if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
htmlTag.className += ' td-md-is-os-x';
}
if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
htmlTag.className += ' td-md-is-chrome';
}
if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
htmlTag.className += ' td-md-is-firefox';
}
if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
htmlTag.className += ' td-md-is-safari';
}
if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
htmlTag.className += ' td-md-is-iemobile';
}
})();
var tdLocalCache = {};
( function () {
"use strict";
tdLocalCache = {
data: {},
remove: function (resource_id) {
delete tdLocalCache.data[resource_id];
},
exist: function (resource_id) {
return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
},
get: function (resource_id) {
return tdLocalCache.data[resource_id];
},
set: function (resource_id, cachedData) {
tdLocalCache.remove(resource_id);
tdLocalCache.data[resource_id] = cachedData;
}
};
})();
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";
var tdc_is_installed="yes";
var td_ajax_url="https:\/\/www.liberianobserver.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=10.2";
var td_get_template_directory_uri="https:\/\/www.liberianobserver.com\/wp-content\/plugins\/td-composer\/legacy\/common";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="show";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#4db2ec";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdBlockNonce="da5eb1a8bd";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-16946754-1', 'auto');
ga('send', 'pageview');
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"item": {
"@type": "WebSite",
"@id": "https://www.liberianobserver.com/",
"name": "Home"
}
},
{
"@type": "ListItem",
"position": 2,
"item": {
"@type": "WebPage",
"@id": "https://www.liberianobserver.com/./opinion/",
"name": "Opinion"
}
}
,{
"@type": "ListItem",
"position": 3,
"item": {
"@type": "WebPage",
"@id": "https://www.liberianobserver.com/./opinion/editorials/",
"name": "Editorials"                                
}
}
,{
"@type": "ListItem",
"position": 4,
"item": {
"@type": "WebPage",
"@id": "https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/",
"name": "Let Not the Baghdad Bobs Ask For Whom the Bells Toll!"                                
}
}    
]
}
</script>
<meta name="twitter:card" content="summary"><meta name="twitter:title" content="Let Not the Baghdad Bobs Ask For Whom the Bells Toll!"><meta name="twitter:description" content="The drama surrounding the missing billions never seems to end with new twists and turns unfolding by the day. Just a few days ago Presidential Press secretary Solo Kelgbeh had announced to the Liberian public that the Legislature had given its approval to the printing of new Liberian dollar banknotes. Prior to the announcement, the&hellip;">
<style type="text/css" id="wp-custom-css">
/*
You can add your own CSS here.
Click the help icon above to learn more.
*/
.cl-popup-trigger img{margin: 5px;}			</style>

<style>
</style>
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript> <style id="tdw-css-placeholder"></style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-139499 single-format-standard td-standard-pack let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll global-block-template-1 single_template_5 wpb-js-composer js-comp-ver-6.0.5 vc_responsive td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/pages/Liberian-Observer-Online/42279623238" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/libobserver/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.titter.com/libobserver" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/locmultimedia" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-28638" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-28638"><a href="https://www.liberianobserver.com">Home</a></li>
<li id="menu-item-28617" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28617"><a href="https://www.liberianobserver.com/./news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><a href="https://www.liberianobserver.com/./news/development/">Development</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/diaspora/">Diaspora</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/legal/">Legal</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/local/">Local</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/media/">Media</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/politics/">Politics</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/security/">Security</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./news/west-africa/">West Africa</a></li>
</ul>
</li>
<li id="menu-item-28585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28585"><a href="https://www.liberianobserver.com/./business/">Business<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./business/investment/">Investment</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./business/markets/">Markets</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./business/opportunities/">Opportunities</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./business/the-economy/">The Economy</a></li>
</ul>
</li>
<li id="menu-item-28623" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-28623"><a href="https://www.liberianobserver.com/./opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./opinion/cartoon/">Cartoon</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./opinion/commentaries/">Commentaries</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./opinion/editorials/">Editorials</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./opinion/letters/">Letters</a></li>
</ul>
</li>
<li id="menu-item-28628" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28628"><a href="https://www.liberianobserver.com/./sports/">Sports<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/athlete-profiles/">Athlete Profiles</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/basketball/">Basketball</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/football/">Football</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/leagues/">Leagues</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/sports-administration/">Sports Administration</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./sports/track-field/">Track &amp; Field</a></li>
</ul>
</li>
<li id="menu-item-28590" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28590"><a href="https://www.liberianobserver.com/./columns/">Columns<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/agriculture/">Agriculture</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/education/">Education</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/environment/">Environment</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/health/">Health</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/religion/">Religion</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/technology/">Technology</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/women/">Women</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./columns/youth/">Youth</a></li>
</ul>
</li>
<li id="menu-item-28604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28604"><a href="https://www.liberianobserver.com/./lib-life/">LIB Life<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/arts/">Arts</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/entertainment/">Entertainment</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/history-us/">History &amp; Us</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/people/">People</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/poetry/">Poetry</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/short-story/">Short Story</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/style/">Style</a></li>
<li class="menu-item-0"><a href="https://www.liberianobserver.com/./lib-life/travel/">Travel</a></li>
</ul>
</li>
<li id="menu-item-28622" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28622"><a href="https://www.liberianobserver.com/./obituaries/">Obituaries</a></li>
<li id="menu-item-78579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78579"><a href="https://www.liberianobserver.com/dev-matters/">Dev Matters</a></li>
<li id="menu-item-50465" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50465"><a href="http://liberiapromisetracker.com/">Election Promises</a></li>
</ul></div> </div>
</div>

<div id="login-form-mobile" class="td-register-section">
<div id="td-login-mob" class="td-login-animation td-login-hide-mob">

<div class="td-login-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Sign in</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
<div class="td-login-info-text">
<a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
</div>
<div class="td-login-register-link">
</div>
</div>
</div>
<div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">

<div class="td-forgot-pass-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Password recovery</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
</div>
</div>
</div>
</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://www.liberianobserver.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-1 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-28852" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-28852"><a href="https://www.scribd.com/Liberian%20Daily%20Observer">E-Edition</a></li>
<li id="menu-item-28964" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-28964"><a href="https://www.liberianobserver.com/wp-login.php">Login</a></li>
<li id="menu-item-28965" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home td-menu-item td-normal-menu menu-item-28965"><a href="https://www.liberianobserver.com">Advertisements</a></li>
<li id="menu-item-28966" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home td-menu-item td-normal-menu menu-item-28966"><a href="https://www.liberianobserver.com">Archives</a></li>
<li id="menu-item-69499" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-69499"><a href="https://www.liberianobserver.com/opportunities/">Opportunities</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/pages/Liberian-Observer-Online/42279623238" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/libobserver/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.titter.com/libobserver" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/locmultimedia" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
<div class="td-container td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.liberianobserver.com/">
<img class="td-retina-data" data-retina="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" src="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" alt="Daily Observer Logo" title="Daily Observer" />
<span class="td-visual-hidden">Liberian Observer</span>
</a>
</div>
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header tdi_1_f22 td_block_template_1 ">
<style>
/* custom css */
.tdi_1_f22.td-a-rec-img{
text-align: left;
}.tdi_1_f22.td-a-rec-img img{
margin: 0 auto 0 0;
}
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;
if ( td_screen_width >= 1140 ) {
/* large monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="3254916944"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
/* landscape tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="3254916944"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
/* portrait tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="3254916944"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width < 768 ) {
/* Phones */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="3254916944"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>

</div> </div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient ">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-header" href="https://www.liberianobserver.com/">
<img class="td-retina-data" data-retina="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" src="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" alt="Daily Observer Logo" title="Daily Observer" />
</a>
<a class="td-header-logo td-sticky-header" href="https://www.liberianobserver.com/">
<img class="td-retina-data" data-retina="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" src="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" alt="Daily Observer Logo" title="Daily Observer" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-28638"><a href="https://www.liberianobserver.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-28617"><a href="https://www.liberianobserver.com/./news/">News</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_2_5a1 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_2_5a1"><script>var block_tdi_2_5a1 = new tdBlock();
block_tdi_2_5a1.id = "tdi_2_5a1";
block_tdi_2_5a1.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"544","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_2_5a1","tdc_css_class":"tdi_2_5a1","tdc_css_class_style":"tdi_2_5a1_rand_style"}';
block_tdi_2_5a1.td_column_number = "3";
block_tdi_2_5a1.block_type = "td_block_mega_menu";
block_tdi_2_5a1.post_count = "4";
block_tdi_2_5a1.found_posts = "16374";
block_tdi_2_5a1.header_color = "";
block_tdi_2_5a1.ajax_pagination_infinite_stop = "";
block_tdi_2_5a1.max_num_pages = "4094";
tdBlocksArray.push(block_tdi_2_5a1);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_2_5a1" id="tdi_3_46d" data-td_block_id="tdi_2_5a1" data-td_filter_value="" href="https://www.liberianobserver.com/./news/">All</a><a class="mega-menu-sub-cat-tdi_2_5a1" id="tdi_4_652" data-td_block_id="tdi_2_5a1" data-td_filter_value="904" href="https://www.liberianobserver.com/./news/development/">Development</a><a class="mega-menu-sub-cat-tdi_2_5a1" id="tdi_5_f5e" data-td_block_id="tdi_2_5a1" data-td_filter_value="1035" href="https://www.liberianobserver.com/./news/diaspora/">Diaspora</a><a class="mega-menu-sub-cat-tdi_2_5a1" id="tdi_6_334" data-td_block_id="tdi_2_5a1" data-td_filter_value="667" href="https://www.liberianobserver.com/./news/legal/">Legal</a><a class="mega-menu-sub-cat-tdi_2_5a1" id="tdi_7_5f1" data-td_block_id="tdi_2_5a1" data-td_filter_value="905" href="https://www.liberianobserver.com/./news/local/">Local</a><a class="mega-menu-sub-cat-tdi_2_5a1" id="tdi_8_d53" data-td_block_id="tdi_2_5a1" data-td_filter_value="1045" href="https://www.liberianobserver.com/./news/media/">Media</a><a class="mega-menu-sub-cat-tdi_2_5a1" id="tdi_9_166" data-td_block_id="tdi_2_5a1" data-td_filter_value="553" href="https://www.liberianobserver.com/./news/politics/">Politics</a><a class="mega-menu-sub-cat-tdi_2_5a1" id="tdi_10_926" data-td_block_id="tdi_2_5a1" data-td_filter_value="555" href="https://www.liberianobserver.com/./news/security/">Security</a><a class="mega-menu-sub-cat-tdi_2_5a1" id="tdi_11_4ff" data-td_block_id="tdi_2_5a1" data-td_filter_value="1041" href="https://www.liberianobserver.com/./news/west-africa/">West Africa</a></div></div><div id=tdi_2_5a1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/major-step-toward-green-card-u-s-citizenship-for-liberians-on-ded/" rel="bookmark" class="td-image-wrap" title="Major Step toward Green Card, U.S. Citizenship for Liberians on DED"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Major Step toward Green Card, U.S. Citizenship for Liberians on DED" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2019/10/Liberian-DED-holders-and-their-allies-protest-in-Worcester-Massachusetts.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/major-step-toward-green-card-u-s-citizenship-for-liberians-on-ded/" rel="bookmark" title="Major Step toward Green Card, U.S. Citizenship for Liberians on DED">Major Step toward Green Card, U.S. Citizenship for Liberians on DED</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/lawmakers-want-cbl-officials-appear-for-questioning/" rel="bookmark" class="td-image-wrap" title="Lawmakers Want CBL Officials Appear for Questioning  "><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Lawmakers Want CBL Officials Appear for Questioning  " data-type="image_tag" data-img-url="https://i1.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/The-lawmakers-argued-that-they-singed-a-resolution-to-change-the-family-of-banknotes-on-the-market-not-to-print-additional-money-of-the-kind-already-in-circulation-1-1-e1576198100206.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./business/" class="td-post-category">Business</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/lawmakers-want-cbl-officials-appear-for-questioning/" rel="bookmark" title="Lawmakers Want CBL Officials Appear for Questioning  ">Lawmakers Want CBL Officials Appear for Questioning  </a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/counselor-brumskine-was-a-resilient-spirit/" rel="bookmark" class="td-image-wrap" title="“Counselor Brumskine Was A Resilient Spirit”"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="“Counselor Brumskine Was A Resilient Spirit”" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/the-late-Brumskine’s-casket-was-escorted-from-the-Samuel-Stryker-funeral-home-by-the-Armed-Forces-of-Liberia-AFL-band-1.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/legal/" class="td-post-category">Legal</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/counselor-brumskine-was-a-resilient-spirit/" rel="bookmark" title="“Counselor Brumskine Was A Resilient Spirit”">“Counselor Brumskine Was A Resilient Spirit”</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/judge-sammy-freezes-controversial-us419k-account-at-access-bank/" rel="bookmark" class="td-image-wrap" title="Judge Sammy Freezes’ Controversial US$419K Account at Access Bank"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Judge Sammy Freezes’ Controversial US$419K Account at Access Bank" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2019/11/Judge-Nancy-Sammy_2-e1573693481802.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/legal/" class="td-post-category">Legal</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/judge-sammy-freezes-controversial-us419k-account-at-access-bank/" rel="bookmark" title="Judge Sammy Freezes’ Controversial US$419K Account at Access Bank">Judge Sammy Freezes’ Controversial US$419K Account at Access Bank</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_2_5a1" data-td_block_id="tdi_2_5a1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_2_5a1" data-td_block_id="tdi_2_5a1"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-28585"><a href="https://www.liberianobserver.com/./business/">Business</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_12_a4a td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_12_a4a"><script>var block_tdi_12_a4a = new tdBlock();
block_tdi_12_a4a.id = "tdi_12_a4a";
block_tdi_12_a4a.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"551","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_12_a4a","tdc_css_class":"tdi_12_a4a","tdc_css_class_style":"tdi_12_a4a_rand_style"}';
block_tdi_12_a4a.td_column_number = "3";
block_tdi_12_a4a.block_type = "td_block_mega_menu";
block_tdi_12_a4a.post_count = "4";
block_tdi_12_a4a.found_posts = "4263";
block_tdi_12_a4a.header_color = "";
block_tdi_12_a4a.ajax_pagination_infinite_stop = "";
block_tdi_12_a4a.max_num_pages = "1066";
tdBlocksArray.push(block_tdi_12_a4a);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_12_a4a" id="tdi_13_45f" data-td_block_id="tdi_12_a4a" data-td_filter_value="" href="https://www.liberianobserver.com/./business/">All</a><a class="mega-menu-sub-cat-tdi_12_a4a" id="tdi_14_6df" data-td_block_id="tdi_12_a4a" data-td_filter_value="558" href="https://www.liberianobserver.com/./business/investment/">Investment</a><a class="mega-menu-sub-cat-tdi_12_a4a" id="tdi_15_5e4" data-td_block_id="tdi_12_a4a" data-td_filter_value="559" href="https://www.liberianobserver.com/./business/markets/">Markets</a><a class="mega-menu-sub-cat-tdi_12_a4a" id="tdi_16_55d" data-td_block_id="tdi_12_a4a" data-td_filter_value="560" href="https://www.liberianobserver.com/./business/opportunities/">Opportunities</a><a class="mega-menu-sub-cat-tdi_12_a4a" id="tdi_17_6fe" data-td_block_id="tdi_12_a4a" data-td_filter_value="557" href="https://www.liberianobserver.com/./business/the-economy/">The Economy</a></div></div><div id=tdi_12_a4a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/lawmakers-want-cbl-officials-appear-for-questioning/" rel="bookmark" class="td-image-wrap" title="Lawmakers Want CBL Officials Appear for Questioning  "><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Lawmakers Want CBL Officials Appear for Questioning  " data-type="image_tag" data-img-url="https://i1.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/The-lawmakers-argued-that-they-singed-a-resolution-to-change-the-family-of-banknotes-on-the-market-not-to-print-additional-money-of-the-kind-already-in-circulation-1-1-e1576198100206.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./business/" class="td-post-category">Business</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/lawmakers-want-cbl-officials-appear-for-questioning/" rel="bookmark" title="Lawmakers Want CBL Officials Appear for Questioning  ">Lawmakers Want CBL Officials Appear for Questioning  </a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/is-govt-really-collecting-its-revenue/" rel="bookmark" class="td-image-wrap" title="Is Gov&#8217;t Really Collecting It&#8217;s Revenue ?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Is Gov&#8217;t Really Collecting It&#8217;s Revenue ?" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/IMG_20191212_104615_0.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./business/" class="td-post-category">Business</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/is-govt-really-collecting-its-revenue/" rel="bookmark" title="Is Gov&#8217;t Really Collecting It&#8217;s Revenue ?">Is Gov&#8217;t Really Collecting It&#8217;s Revenue ?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/world-bank-sida-donates-42-bikes-to-yop-county-facilitators/" rel="bookmark" class="td-image-wrap" title="World Bank, SIDA Donates 42 Bikes to YOP County Facilitators"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="World Bank, SIDA Donates 42 Bikes to YOP County Facilitators" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/IMG-20191212-WA0002-1.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./columns/agriculture/" class="td-post-category">Agriculture</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/world-bank-sida-donates-42-bikes-to-yop-county-facilitators/" rel="bookmark" title="World Bank, SIDA Donates 42 Bikes to YOP County Facilitators">World Bank, SIDA Donates 42 Bikes to YOP County Facilitators</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/cbl-hosts-3rd-economic-forum-of-financial-inclusion-today/" rel="bookmark" class="td-image-wrap" title="CBL Hosts 3rd Economic Forum of Financial Inclusion Today"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="CBL Hosts 3rd Economic Forum of Financial Inclusion Today" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2018/12/CBL.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./business/" class="td-post-category">Business</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/cbl-hosts-3rd-economic-forum-of-financial-inclusion-today/" rel="bookmark" title="CBL Hosts 3rd Economic Forum of Financial Inclusion Today">CBL Hosts 3rd Economic Forum of Financial Inclusion Today</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_12_a4a" data-td_block_id="tdi_12_a4a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_12_a4a" data-td_block_id="tdi_12_a4a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-mega-menu menu-item-28623"><a href="https://www.liberianobserver.com/./opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_18_928 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_18_928"><script>var block_tdi_18_928 = new tdBlock();
block_tdi_18_928.id = "tdi_18_928";
block_tdi_18_928.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"547","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_18_928","tdc_css_class":"tdi_18_928","tdc_css_class_style":"tdi_18_928_rand_style"}';
block_tdi_18_928.td_column_number = "3";
block_tdi_18_928.block_type = "td_block_mega_menu";
block_tdi_18_928.post_count = "4";
block_tdi_18_928.found_posts = "3341";
block_tdi_18_928.header_color = "";
block_tdi_18_928.ajax_pagination_infinite_stop = "";
block_tdi_18_928.max_num_pages = "836";
tdBlocksArray.push(block_tdi_18_928);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_18_928" id="tdi_19_d94" data-td_block_id="tdi_18_928" data-td_filter_value="" href="https://www.liberianobserver.com/./opinion/">All</a><a class="mega-menu-sub-cat-tdi_18_928" id="tdi_20_9cb" data-td_block_id="tdi_18_928" data-td_filter_value="561" href="https://www.liberianobserver.com/./opinion/cartoon/">Cartoon</a><a class="mega-menu-sub-cat-tdi_18_928" id="tdi_21_1df" data-td_block_id="tdi_18_928" data-td_filter_value="550" href="https://www.liberianobserver.com/./opinion/commentaries/">Commentaries</a><a class="mega-menu-sub-cat-tdi_18_928" id="tdi_22_4db" data-td_block_id="tdi_18_928" data-td_filter_value="546" href="https://www.liberianobserver.com/./opinion/editorials/">Editorials</a><a class="mega-menu-sub-cat-tdi_18_928" id="tdi_23_f25" data-td_block_id="tdi_18_928" data-td_filter_value="549" href="https://www.liberianobserver.com/./opinion/letters/">Letters</a></div></div><div id=tdi_18_928 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/" rel="bookmark" class="td-image-wrap" title="Let Not the Baghdad Bobs Ask For Whom the Bells Toll!"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/editorials/" class="td-post-category">Editorials</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/" rel="bookmark" title="Let Not the Baghdad Bobs Ask For Whom the Bells Toll!">Let Not the Baghdad Bobs Ask For Whom the Bells Toll!</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/lets-lecture-a-tribute-to-the-late-harry-a-greaves-2/" rel="bookmark" class="td-image-wrap" title="Let’s Lecture: A Tribute To The Late Harry A. Greaves"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Harry Greaves.jpg" title="Let’s Lecture: A Tribute To The Late Harry A. Greaves" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2015/06/Harry Greaves_3-e1576186672474.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/commentaries/" class="td-post-category">Commentaries</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/lets-lecture-a-tribute-to-the-late-harry-a-greaves-2/" rel="bookmark" title="Let’s Lecture: A Tribute To The Late Harry A. Greaves">Let’s Lecture: A Tribute To The Late Harry A. Greaves</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/editorials/are-they-reading-and-are-they-listening/" rel="bookmark" class="td-image-wrap" title="Are They Reading and Are They Listening?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/editorials/" class="td-post-category">Editorials</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/editorials/are-they-reading-and-are-they-listening/" rel="bookmark" title="Are They Reading and Are They Listening?">Are They Reading and Are They Listening?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/editorials/they-cannot-excuse-themselves-neither-will-the-public-morlu-and-gray/" rel="bookmark" class="td-image-wrap" title="They Cannot Excuse Themselves, Neither Will The Public: Morlu And Gray!"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/editorials/" class="td-post-category">Editorials</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/editorials/they-cannot-excuse-themselves-neither-will-the-public-morlu-and-gray/" rel="bookmark" title="They Cannot Excuse Themselves, Neither Will The Public: Morlu And Gray!">They Cannot Excuse Themselves, Neither Will The Public: Morlu And Gray!</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_18_928" data-td_block_id="tdi_18_928"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_18_928" data-td_block_id="tdi_18_928"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-28628"><a href="https://www.liberianobserver.com/./sports/">Sports</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_24_020 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_24_020"><script>var block_tdi_24_020 = new tdBlock();
block_tdi_24_020.id = "tdi_24_020";
block_tdi_24_020.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"545","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_24_020","tdc_css_class":"tdi_24_020","tdc_css_class_style":"tdi_24_020_rand_style"}';
block_tdi_24_020.td_column_number = "3";
block_tdi_24_020.block_type = "td_block_mega_menu";
block_tdi_24_020.post_count = "4";
block_tdi_24_020.found_posts = "2218";
block_tdi_24_020.header_color = "";
block_tdi_24_020.ajax_pagination_infinite_stop = "";
block_tdi_24_020.max_num_pages = "555";
tdBlocksArray.push(block_tdi_24_020);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_24_020" id="tdi_25_d6f" data-td_block_id="tdi_24_020" data-td_filter_value="" href="https://www.liberianobserver.com/./sports/">All</a><a class="mega-menu-sub-cat-tdi_24_020" id="tdi_26_e26" data-td_block_id="tdi_24_020" data-td_filter_value="564" href="https://www.liberianobserver.com/./sports/athlete-profiles/">Athlete Profiles</a><a class="mega-menu-sub-cat-tdi_24_020" id="tdi_27_54f" data-td_block_id="tdi_24_020" data-td_filter_value="563" href="https://www.liberianobserver.com/./sports/basketball/">Basketball</a><a class="mega-menu-sub-cat-tdi_24_020" id="tdi_28_96f" data-td_block_id="tdi_24_020" data-td_filter_value="562" href="https://www.liberianobserver.com/./sports/football/">Football</a><a class="mega-menu-sub-cat-tdi_24_020" id="tdi_29_922" data-td_block_id="tdi_24_020" data-td_filter_value="565" href="https://www.liberianobserver.com/./sports/leagues/">Leagues</a><a class="mega-menu-sub-cat-tdi_24_020" id="tdi_30_2e4" data-td_block_id="tdi_24_020" data-td_filter_value="566" href="https://www.liberianobserver.com/./sports/sports-administration/">Sports Administration</a><a class="mega-menu-sub-cat-tdi_24_020" id="tdi_31_9e4" data-td_block_id="tdi_24_020" data-td_filter_value="1032" href="https://www.liberianobserver.com/./sports/track-field/">Track &amp; Field</a></div></div><div id=tdi_24_020 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/milton-jones-wins-second-mvp-award-in-usa/" rel="bookmark" class="td-image-wrap" title="Milton Jones Wins Second MVP Award in USA"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Milton Jones Wins Second MVP Award in USA" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/Milton-Jones-MVP.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./sports/athlete-profiles/" class="td-post-category">Athlete Profiles</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/milton-jones-wins-second-mvp-award-in-usa/" rel="bookmark" title="Milton Jones Wins Second MVP Award in USA">Milton Jones Wins Second MVP Award in USA</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/four-liberian-referees-off-to-egypt/" rel="bookmark" class="td-image-wrap" title="Four Liberian Referees Off to Egypt"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Four Liberian Referees Off to Egypt" data-type="image_tag" data-img-url="https://i1.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/received_972397276460827.jpeg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./sports/football/" class="td-post-category">Football</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/four-liberian-referees-off-to-egypt/" rel="bookmark" title="Four Liberian Referees Off to Egypt">Four Liberian Referees Off to Egypt</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/master-queen-organizes-soccer-jamboree-to-kickoff-dec-6/" rel="bookmark" class="td-image-wrap" title="Master Queen&#8217;s Soccer Jamboree to Kickoff Dec. 6"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Master Queen&#8217;s Soccer Jamboree to Kickoff Dec. 6" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/Master-Queen.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/master-queen-organizes-soccer-jamboree-to-kickoff-dec-6/" rel="bookmark" title="Master Queen&#8217;s Soccer Jamboree to Kickoff Dec. 6">Master Queen&#8217;s Soccer Jamboree to Kickoff Dec. 6</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/barca-fan-club-launched-in-liberia/" rel="bookmark" class="td-image-wrap" title="Barca Fan Club Launched in Liberia"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Barca Fan Club Launched in Liberia" data-type="image_tag" data-img-url="https://i1.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/BARCA-2.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./sports/athlete-profiles/" class="td-post-category">Athlete Profiles</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/barca-fan-club-launched-in-liberia/" rel="bookmark" title="Barca Fan Club Launched in Liberia">Barca Fan Club Launched in Liberia</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_24_020" data-td_block_id="tdi_24_020"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_24_020" data-td_block_id="tdi_24_020"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-28590"><a href="https://www.liberianobserver.com/./columns/">Columns</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_32_49f td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_32_49f"><script>var block_tdi_32_49f = new tdBlock();
block_tdi_32_49f.id = "tdi_32_49f";
block_tdi_32_49f.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"567","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_32_49f","tdc_css_class":"tdi_32_49f","tdc_css_class_style":"tdi_32_49f_rand_style"}';
block_tdi_32_49f.td_column_number = "3";
block_tdi_32_49f.block_type = "td_block_mega_menu";
block_tdi_32_49f.post_count = "4";
block_tdi_32_49f.found_posts = "6069";
block_tdi_32_49f.header_color = "";
block_tdi_32_49f.ajax_pagination_infinite_stop = "";
block_tdi_32_49f.max_num_pages = "1518";
tdBlocksArray.push(block_tdi_32_49f);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_32_49f" id="tdi_33_fd5" data-td_block_id="tdi_32_49f" data-td_filter_value="" href="https://www.liberianobserver.com/./columns/">All</a><a class="mega-menu-sub-cat-tdi_32_49f" id="tdi_34_493" data-td_block_id="tdi_32_49f" data-td_filter_value="568" href="https://www.liberianobserver.com/./columns/agriculture/">Agriculture</a><a class="mega-menu-sub-cat-tdi_32_49f" id="tdi_35_946" data-td_block_id="tdi_32_49f" data-td_filter_value="569" href="https://www.liberianobserver.com/./columns/education/">Education</a><a class="mega-menu-sub-cat-tdi_32_49f" id="tdi_36_53d" data-td_block_id="tdi_32_49f" data-td_filter_value="570" href="https://www.liberianobserver.com/./columns/environment/">Environment</a><a class="mega-menu-sub-cat-tdi_32_49f" id="tdi_37_254" data-td_block_id="tdi_32_49f" data-td_filter_value="571" href="https://www.liberianobserver.com/./columns/health/">Health</a><a class="mega-menu-sub-cat-tdi_32_49f" id="tdi_38_ee2" data-td_block_id="tdi_32_49f" data-td_filter_value="581" href="https://www.liberianobserver.com/./columns/religion/">Religion</a><a class="mega-menu-sub-cat-tdi_32_49f" id="tdi_39_d3b" data-td_block_id="tdi_32_49f" data-td_filter_value="572" href="https://www.liberianobserver.com/./columns/technology/">Technology</a><a class="mega-menu-sub-cat-tdi_32_49f" id="tdi_40_9e1" data-td_block_id="tdi_32_49f" data-td_filter_value="573" href="https://www.liberianobserver.com/./columns/women/">Women</a><a class="mega-menu-sub-cat-tdi_32_49f" id="tdi_41_d22" data-td_block_id="tdi_32_49f" data-td_filter_value="574" href="https://www.liberianobserver.com/./columns/youth/">Youth</a></div></div><div id=tdi_32_49f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/major-step-toward-green-card-u-s-citizenship-for-liberians-on-ded/" rel="bookmark" class="td-image-wrap" title="Major Step toward Green Card, U.S. Citizenship for Liberians on DED"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Major Step toward Green Card, U.S. Citizenship for Liberians on DED" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2019/10/Liberian-DED-holders-and-their-allies-protest-in-Worcester-Massachusetts.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/major-step-toward-green-card-u-s-citizenship-for-liberians-on-ded/" rel="bookmark" title="Major Step toward Green Card, U.S. Citizenship for Liberians on DED">Major Step toward Green Card, U.S. Citizenship for Liberians on DED</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/67-5-of-all-sgbv-cases-reported-january-september-2019-involved-rape/" rel="bookmark" class="td-image-wrap" title="67.5% of All SGBV Cases Reported January &#8211; September 2019 Involved Rape"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="67.5% of All SGBV Cases Reported January &#8211; September 2019 Involved Rape" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/ICHR-1.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./news/development/" class="td-post-category">Development</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/67-5-of-all-sgbv-cases-reported-january-september-2019-involved-rape/" rel="bookmark" title="67.5% of All SGBV Cases Reported January &#8211; September 2019 Involved Rape">67.5% of All SGBV Cases Reported January &#8211; September 2019 Involved&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/world-bank-sida-donates-42-bikes-to-yop-county-facilitators/" rel="bookmark" class="td-image-wrap" title="World Bank, SIDA Donates 42 Bikes to YOP County Facilitators"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="World Bank, SIDA Donates 42 Bikes to YOP County Facilitators" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/IMG-20191212-WA0002-1.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./columns/agriculture/" class="td-post-category">Agriculture</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/world-bank-sida-donates-42-bikes-to-yop-county-facilitators/" rel="bookmark" title="World Bank, SIDA Donates 42 Bikes to YOP County Facilitators">World Bank, SIDA Donates 42 Bikes to YOP County Facilitators</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/cbl-hosts-3rd-economic-forum-of-financial-inclusion-today/" rel="bookmark" class="td-image-wrap" title="CBL Hosts 3rd Economic Forum of Financial Inclusion Today"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="CBL Hosts 3rd Economic Forum of Financial Inclusion Today" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2018/12/CBL.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./business/" class="td-post-category">Business</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/cbl-hosts-3rd-economic-forum-of-financial-inclusion-today/" rel="bookmark" title="CBL Hosts 3rd Economic Forum of Financial Inclusion Today">CBL Hosts 3rd Economic Forum of Financial Inclusion Today</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_32_49f" data-td_block_id="tdi_32_49f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_32_49f" data-td_block_id="tdi_32_49f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-28604"><a href="https://www.liberianobserver.com/./lib-life/">LIB Life</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_42_527 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_42_527"><script>var block_tdi_42_527 = new tdBlock();
block_tdi_42_527.id = "tdi_42_527";
block_tdi_42_527.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"552","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_42_527","tdc_css_class":"tdi_42_527","tdc_css_class_style":"tdi_42_527_rand_style"}';
block_tdi_42_527.td_column_number = "3";
block_tdi_42_527.block_type = "td_block_mega_menu";
block_tdi_42_527.post_count = "4";
block_tdi_42_527.found_posts = "2120";
block_tdi_42_527.header_color = "";
block_tdi_42_527.ajax_pagination_infinite_stop = "";
block_tdi_42_527.max_num_pages = "530";
tdBlocksArray.push(block_tdi_42_527);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_42_527" id="tdi_43_2e2" data-td_block_id="tdi_42_527" data-td_filter_value="" href="https://www.liberianobserver.com/./lib-life/">All</a><a class="mega-menu-sub-cat-tdi_42_527" id="tdi_44_ff7" data-td_block_id="tdi_42_527" data-td_filter_value="575" href="https://www.liberianobserver.com/./lib-life/arts/">Arts</a><a class="mega-menu-sub-cat-tdi_42_527" id="tdi_45_05c" data-td_block_id="tdi_42_527" data-td_filter_value="580" href="https://www.liberianobserver.com/./lib-life/entertainment/">Entertainment</a><a class="mega-menu-sub-cat-tdi_42_527" id="tdi_46_e39" data-td_block_id="tdi_42_527" data-td_filter_value="582" href="https://www.liberianobserver.com/./lib-life/history-us/">History &amp; Us</a><a class="mega-menu-sub-cat-tdi_42_527" id="tdi_47_56d" data-td_block_id="tdi_42_527" data-td_filter_value="839" href="https://www.liberianobserver.com/./lib-life/people/">People</a><a class="mega-menu-sub-cat-tdi_42_527" id="tdi_48_e4f" data-td_block_id="tdi_42_527" data-td_filter_value="578" href="https://www.liberianobserver.com/./lib-life/poetry/">Poetry</a><a class="mega-menu-sub-cat-tdi_42_527" id="tdi_49_3c3" data-td_block_id="tdi_42_527" data-td_filter_value="577" href="https://www.liberianobserver.com/./lib-life/short-story/">Short Story</a><a class="mega-menu-sub-cat-tdi_42_527" id="tdi_50_f2f" data-td_block_id="tdi_42_527" data-td_filter_value="576" href="https://www.liberianobserver.com/./lib-life/style/">Style</a><a class="mega-menu-sub-cat-tdi_42_527" id="tdi_51_ee9" data-td_block_id="tdi_42_527" data-td_filter_value="579" href="https://www.liberianobserver.com/./lib-life/travel/">Travel</a></div></div><div id=tdi_42_527 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/cari-workers-on-strike-want-dismissed-employee-re-instated/" rel="bookmark" class="td-image-wrap" title="CARI Workers on Strike, Want Dismissed Employee Re-instated"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="CARI Workers on Strike, Want Dismissed Employee Re-instated" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/IMG_9921-scaled.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./columns/agriculture/" class="td-post-category">Agriculture</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/cari-workers-on-strike-want-dismissed-employee-re-instated/" rel="bookmark" title="CARI Workers on Strike, Want Dismissed Employee Re-instated">CARI Workers on Strike, Want Dismissed Employee Re-instated</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/linam-hosts-swedish-jazz-trio-in-christmas-concert/" rel="bookmark" class="td-image-wrap" title="LINAM Hosts Swedish Jazz Trio in Christmas Concert"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="LINAM Hosts Swedish Jazz Trio in Christmas Concert" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/Swedish-Jazz-Musicians.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./lib-life/arts/" class="td-post-category">Arts</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/linam-hosts-swedish-jazz-trio-in-christmas-concert/" rel="bookmark" title="LINAM Hosts Swedish Jazz Trio in Christmas Concert">LINAM Hosts Swedish Jazz Trio in Christmas Concert</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/transco-clsg-to-complete-4-substations-in-2020/" rel="bookmark" class="td-image-wrap" title="TRANSCO CLSG to Complete 4 Substations in 2020"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="TRANSCO CLSG to Complete 4 Substations in 2020" data-type="image_tag" data-img-url="https://i2.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/CLSG-3.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./business/" class="td-post-category">Business</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/transco-clsg-to-complete-4-substations-in-2020/" rel="bookmark" title="TRANSCO CLSG to Complete 4 Substations in 2020">TRANSCO CLSG to Complete 4 Substations in 2020</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/air-france-resumes-service-to-liberia-starting-april-2020/" rel="bookmark" class="td-image-wrap" title="Air France Resumes Service to Liberia Starting April 2020"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Air France Resumes Service to Liberia Starting April 2020" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/Air-France.jpg?resize=218%2C150&#038;ssl=1" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./business/" class="td-post-category">Business</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/air-france-resumes-service-to-liberia-starting-april-2020/" rel="bookmark" title="Air France Resumes Service to Liberia Starting April 2020">Air France Resumes Service to Liberia Starting April 2020</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_42_527" data-td_block_id="tdi_42_527"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_42_527" data-td_block_id="tdi_42_527"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-28622"><a href="https://www.liberianobserver.com/./obituaries/">Obituaries</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-78579"><a href="https://www.liberianobserver.com/dev-matters/">Dev Matters</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-50465"><a href="http://liberiapromisetracker.com/">Election Promises</a></li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.liberianobserver.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-5 ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.liberianobserver.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Opinion" class="entry-crumb" href="https://www.liberianobserver.com/./opinion/">Opinion</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Editorials" class="entry-crumb" href="https://www.liberianobserver.com/./opinion/editorials/">Editorials</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Let Not the Baghdad Bobs Ask For Whom the Bells Toll!</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-139499" class="post-139499 post type-post status-publish format-standard category-editorials" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="https://www.liberianobserver.com/./opinion/">Opinion</a></li><li class="entry-category"><a href="https://www.liberianobserver.com/./opinion/editorials/">Editorials</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">Let Not the Baghdad Bobs Ask For Whom the Bells Toll!</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.liberianobserver.com/author/webmaster/">Webmaster Admin</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-12-16T02:17:00+00:00">December 16, 2019</time></span> <div class="td-post-comments"><a href="https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/#respond"><i class="td-icon-comments"></i>0</a></div> <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-139499">32</span></div> </div>
</header>
</div>
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Feditorials%2Flet-not-the-baghdad-bobs-ask-for-whom-the-bells-toll%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Let+Not+the+Baghdad+Bobs+Ask+For+Whom+the+Bells+Toll%21&url=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Feditorials%2Flet-not-the-baghdad-bobs-ask-for-whom-the-bells-toll%2F&via=Libobserver">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/&amp;media=&description=Let+Not+the+Baghdad+Bobs+Ask+For+Whom+the+Bells+Toll%21">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Let+Not+the+Baghdad+Bobs+Ask+For+Whom+the+Bells+Toll%21 %0A%0A https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content">
<p>The drama surrounding the missing billions never seems to end with new twists and turns unfolding by the day. Just a few days ago Presidential Press secretary Solo Kelgbeh had announced to the Liberian public that the Legislature had given its approval to the printing of new Liberian dollar banknotes.</p>
<p>Prior to the announcement, the nation was informed that the Legislature was being recalled from break to discuss a singular agenda item, which was the proposed printing of new Liberian dollar banknotes to, as was said, to ease the liquidity situation facing the country. This was very puzzling because 16 billion in Liberian dollar banknotes had been printed and brought into the country.</p>
<p>When alarm was raised that some of the money had gone missing, the government went at lengths to prove that no money had gone missing although, the ruling party chairman, Mulbah Morlu had publicly disclosed that he personally saw pick-up truck loads of money being carted away from the CBL’s Waterside vaults.</p>
<p>Official probes were commissioned by President Weah in order to get to the bottom of the matter including that of the scandal surrounding the US$ 25 million infusion. At the end of the day, it came down to doing an actual physical count money held in the CBL’s vaults. To the shocking surprise of the public, officials of the CBL denied fraud investigators access to its vaults.</p>
<p>President Weah failed to order then CBL Governor Nathaniel Patray to comply with the KROLL and PIT requests for access to the CBL’s vaults. Resultantly, the total amount of money held by the CBL remained unaccounted for. Over the last few months the public has experienced an acute shortage of Liberian dollars, leaving many to question just where did the 16 billion worth of Liberian dollar banknotes go?</p>
<p>According to a financial analyst (name withheld), Finance Minister Samuel Tweah’s apparent takeover of Government’s Monetary and Fiscal policies has proved disastrous to the health of the nation’s economy. The introduction of newly printed banknotes is raising much public ire given that the money being paid out are all in the LD500 denomination. And it is being paid out mainly to members of the Legislature.</p>
<p>This situation has not gone down well with the public and now Representatives Larry Younquoi and Thomas Goshua calling on their colleagues to have authorities of the CBL appear before them to provide information on the source of the US and Liberian dollars it recently infused into the market. At bar also is the issue of propriety or the lack of it which needs to be addressed.</p>
<p>Two members of the Independent Legislative Caucus, Representatives Larry Younquoi and Thomas Goshua, are asking the plenary of the House of Representatives to invite authorities of the Central Bank of Liberia to explain the source of US and Liberian currencies it infused in the market recently.</p>
<p>Meanwhile, the civil servants association has announced that as of Monday, December 16, they will begin a go-slow protest action in demand of their wages now having gone unpaid for months. And there is rising public concern that ordinary people are unable to withdraw Liberian dollars from their accounts and may have a very bleak Christmas.</p>
<p>Local SuSu and other savings and loans associations usually make annual payouts to their members in December of each year. With December already gone beyond the half-way mark, there is considerable public unease about prospects of being let down.</p>
<p>In view of these developments, it would not be surprising to see an even greater number of people showing up on the streets on December 30 as compared to the mass protest of last June 7.</p>
<p>Realizing that such a mass protest could severely expose the weakness of this government, its officials are going all out, leaving no stones unturned to either dissuade protest organizers or to threaten the use of violence.</p>
<p>Over the weekend a group of individuals, led by a former representative and deputy minister, staged a march thru the streets calling on people not to listen to people who want to bring war to the country referring to the organizers of the planned December 30 protest.</p>
<p>As things appear, the public does not know what to believe with so many self-contradictory statements coming from various government officials. And in situations where the people lose faith in their government, not even armed or military might can prove enough to stop them from taking destiny in their own hands.</p>
<p>At least this was or should be the lesson learned from Burkina Faso where a bloody dictator held sway over his people for decades decreeing who lived or who died. The hawkish but cowardly Bagdad Bobs will of course as expected to come out charging, accusing this newspaper of partisan bias.</p>
<p>But the <em>Daily Observer</em> remains unmoved by such and shall not fail to keep ringing the bells and, let not the Baghdad Bobs of this world ask for whom the bells toll.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-139499" class="share-twitter sd-button share-icon no-text" href="https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-139499" class="share-facebook sd-button share-icon no-text" href="https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_bottom tdi_52_e99 td_block_template_1 ">
<style>
/* custom css */
.tdi_52_e99.td-a-rec-img{
text-align: left;
}.tdi_52_e99.td-a-rec-img img{
margin: 0 auto 0 0;
}
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;
if ( td_screen_width >= 1140 ) {
/* large monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="6940868918"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
/* landscape tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="6940868918"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
/* portrait tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="6940868918"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width < 768 ) {
/* Phones */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="6940868918"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>

</div>
<footer>
<div class="td-post-source-tags">
</div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Feditorials%2Flet-not-the-baghdad-bobs-ask-for-whom-the-bells-toll%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Let+Not+the+Baghdad+Bobs+Ask+For+Whom+the+Bells+Toll%21&url=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Feditorials%2Flet-not-the-baghdad-bobs-ask-for-whom-the-bells-toll%2F&via=Libobserver">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/&amp;media=&description=Let+Not+the+Baghdad+Bobs+Ask+For+Whom+the+Bells+Toll%21">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Let+Not+the+Baghdad+Bobs+Ask+For+Whom+the+Bells+Toll%21 %0A%0A https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.liberianobserver.com/news/major-step-toward-green-card-u-s-citizenship-for-liberians-on-ded/">Major Step toward Green Card, U.S. Citizenship for Liberians on DED</a></div></div><div class="td-next-prev-separator"></div></div> <div class="author-box-wrap"><a href="https://www.liberianobserver.com/author/webmaster/"><img alt src="https://secure.gravatar.com/avatar/5e9b534a27f656df74010f2d4f482a19?s=96&#038;d=mm&#038;r=g" class="avatar avatar-96 photo jetpack-lazy-image" height="96" width="96" data-lazy-srcset="https://secure.gravatar.com/avatar/5e9b534a27f656df74010f2d4f482a19?s=192&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/5e9b534a27f656df74010f2d4f482a19?s=96&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/5e9b534a27f656df74010f2d4f482a19?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/5e9b534a27f656df74010f2d4f482a19?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></noscript></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.liberianobserver.com/author/webmaster/">Webmaster Admin</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Webmaster Admin"></span><meta itemprop="datePublished" content="2019-12-16T02:17:00+00:00"><meta itemprop="dateModified" content="2019-12-14T05:25:58+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.liberianobserver.com/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png"></span><meta itemprop="name" content="Liberian Observer"></span><meta itemprop="headline " content="Let Not the Baghdad Bobs Ask For Whom the Bells Toll!"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.liberianobserver.com/wp-content/themes/Newspaper/images/no-thumb/td_meta_replacement.png"><meta itemprop="width" content="1068"><meta itemprop="height" content="580"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts tdi_53_a64 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_53_a64"><script>var block_tdi_53_a64 = new tdBlock();
block_tdi_53_a64.id = "tdi_53_a64";
block_tdi_53_a64.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_53_a64","td_column_number":3,"live_filter_cur_post_id":139499,"live_filter_cur_post_author":"1","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_53_a64","tdc_css_class_style":"tdi_53_a64_rand_style"}';
block_tdi_53_a64.td_column_number = "3";
block_tdi_53_a64.block_type = "td_block_related_posts";
block_tdi_53_a64.post_count = "3";
block_tdi_53_a64.found_posts = "1492";
block_tdi_53_a64.header_color = "";
block_tdi_53_a64.ajax_pagination_infinite_stop = "";
block_tdi_53_a64.max_num_pages = "498";
tdBlocksArray.push(block_tdi_53_a64);
</script><h4 class="td-related-title td-block-title"><a id="tdi_54_4f2" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_53_a64" href="#">RELATED ARTICLES</a><a id="tdi_55_6e5" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_53_a64" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_53_a64 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/editorials/are-they-reading-and-are-they-listening/" rel="bookmark" class="td-image-wrap" title="Are They Reading and Are They Listening?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/editorials/" class="td-post-category">Editorials</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/editorials/are-they-reading-and-are-they-listening/" rel="bookmark" title="Are They Reading and Are They Listening?">Are They Reading and Are They Listening?</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/editorials/they-cannot-excuse-themselves-neither-will-the-public-morlu-and-gray/" rel="bookmark" class="td-image-wrap" title="They Cannot Excuse Themselves, Neither Will The Public: Morlu And Gray!"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/editorials/" class="td-post-category">Editorials</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/editorials/they-cannot-excuse-themselves-neither-will-the-public-morlu-and-gray/" rel="bookmark" title="They Cannot Excuse Themselves, Neither Will The Public: Morlu And Gray!">They Cannot Excuse Themselves, Neither Will The Public: Morlu And Gray!</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/opinion/editorials/is-a-step-down-protest-unconstitutional/" rel="bookmark" class="td-image-wrap" title="Is A “Step-down Protest” Unconstitutional?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" data-type="image_tag" data-img-url="https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png" width="218" height="150" /></a></div> <a href="https://www.liberianobserver.com/./opinion/editorials/" class="td-post-category">Editorials</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/opinion/editorials/is-a-step-down-protest-unconstitutional/" rel="bookmark" title="Is A “Step-down Protest” Unconstitutional?">Is A “Step-down Protest” Unconstitutional?</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_53_a64" data-td_block_id="tdi_53_a64"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_53_a64" data-td_block_id="tdi_53_a64"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div class="comments" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/opinion/editorials/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll/?utm_campaign=coschedule&amp;utm_content=Let+Not+the+Baghdad+Bobs+Ask+For+Whom+the+Bells+Toll%21&amp;utm_medium=Liberian+Observer+Online&amp;utm_source=facebook_page#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=125373089&#038;postid=139499&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=7.9.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=dcf2b5f28ed1b81facc8f74e09b5d673729d5383#parent=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Feditorials%2Flet-not-the-baghdad-bobs-ask-for-whom-the-bells-toll%2F%3Futm_campaign%3Dcoschedule%26utm_content%3DLet%2BNot%2Bthe%2BBaghdad%2BBobs%2BAsk%2BFor%2BWhom%2Bthe%2BBells%2BToll%2521%26utm_medium%3DLiberian%2BObserver%2BOnline%26utm_source%3Dfacebook_page" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
<!--[if !IE]><!-->
<script>
document.addEventListener('DOMContentLoaded', function () {
var commentForms = document.getElementsByClassName('jetpack_remote_comment');
for (var i = 0; i < commentForms.length; i++) {
commentForms[i].allowTransparency = false;
commentForms[i].scrolling = 'no';
}
});
</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div data-embed="widget"><script type="text/props">{"action":"add-to-cart","colors":{"buttons":{"background":"#7959c7","text":"#ffffff"},"checkout":{"background":"#7959c7","text":"#ffffff"}},"description":true,"logos":true,"modal":true,"text":"Add to cart","url":"https://selz.co/NkeHswVtU","width":400}</script></div>
<script async src="https://embeds.selzstatic.com/1/loader.js"></script>
<noscript><a href="https://selz.co/NkeHswVtU" target="_blank" rel="noopener noreferrer">Add to cart</a></noscript></div></aside>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar tdi_56_455 td_block_template_1 ">
<style>
/* custom css */
.tdi_56_455.td-a-rec-img{
text-align: left;
}.tdi_56_455.td-a-rec-img img{
margin: 0 auto 0 0;
}
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;
if ( td_screen_width >= 1140 ) {
/* large monitors */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2510669317"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
/* landscape tablets */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2510669317"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
/* portrait tablets */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2510669317"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width < 768 ) {
/* Phones */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6475113583811280" data-ad-slot="2510669317"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>

<aside class="widget_text td_block_template_1 widget widget_custom_html"><h4 class="block-title"><span>Related News</span></h4><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-6475113583811280" data-ad-slot="5555173659"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside class="td_block_template_1 widget widget_recent_comments"><h4 class="block-title"><span>Join the Conversation</span></h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Hney</span> on <a href="https://www.liberianobserver.com/news/only-in-unity-of-purpose-can-liberians-make-a-better-country/#comment-91581">&#8216;Only in Unity of Purpose Can Liberians Make A Better Country&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Hney</span> on <a href="https://www.liberianobserver.com/news/major-step-toward-green-card-u-s-citizenship-for-liberians-on-ded/#comment-91580">Major Step toward Green Card, U.S. Citizenship for Liberians on DED</a></li><li class="recentcomments"><span class="comment-author-link">Hney</span> on <a href="https://www.liberianobserver.com/news/major-step-toward-green-card-u-s-citizenship-for-liberians-on-ded/#comment-91579">Major Step toward Green Card, U.S. Citizenship for Liberians on DED</a></li><li class="recentcomments"><span class="comment-author-link">Aaron Doe Nelson Sr. Minneapolis, USA</span> on <a href="https://www.liberianobserver.com/news/only-in-unity-of-purpose-can-liberians-make-a-better-country/#comment-91578">&#8216;Only in Unity of Purpose Can Liberians Make A Better Country&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Mamadu Sulahman Bah</span> on <a href="https://www.liberianobserver.com/news/major-step-toward-green-card-u-s-citizenship-for-liberians-on-ded/#comment-91577">Major Step toward Green Card, U.S. Citizenship for Liberians on DED</a></li><li class="recentcomments"><span class="comment-author-link">Hney</span> on <a href="https://www.liberianobserver.com/news/only-in-unity-of-purpose-can-liberians-make-a-better-country/#comment-91576">&#8216;Only in Unity of Purpose Can Liberians Make A Better Country&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">CHARLES JOHNSON</span> on <a href="https://www.liberianobserver.com/news/lawmakers-want-cbl-officials-appear-for-questioning/#comment-91575">Lawmakers Want CBL Officials Appear for Questioning  </a></li><li class="recentcomments"><span class="comment-author-link">Petarus Dolo</span> on <a href="https://www.liberianobserver.com/news/only-in-unity-of-purpose-can-liberians-make-a-better-country/#comment-91574">&#8216;Only in Unity of Purpose Can Liberians Make A Better Country&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Aaron Doe Nelson Sr. Minneapolis, USA</span> on <a href="https://www.liberianobserver.com/news/only-in-unity-of-purpose-can-liberians-make-a-better-country/#comment-91572">&#8216;Only in Unity of Purpose Can Liberians Make A Better Country&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Hney</span> on <a href="https://www.liberianobserver.com/news/only-in-unity-of-purpose-can-liberians-make-a-better-country/#comment-91571">&#8216;Only in Unity of Purpose Can Liberians Make A Better Country&#8217;</a></li></ul></aside> </div>
</div>
</div> 
</div> 
</div> 


<div class="td-footer-wrapper td-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span8">
</div>
<div class="td-pb-span4">
</div>
</div>
</div>
<div class="td-footer-bottom-full">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.liberianobserver.com/"><img class="td-retina-data" src="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" data-retina="https://liberianobserver.com/wp-content/uploads/2017/03/Observer_logo_2-300x70-300x70.png" alt="Daily Observer Logo" title="Daily Observer" width="" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Liberianobserver.com is the online version of its print edition, the Daily Observer newspaper, a product of the Liberian Observer Corporation. The Daily Observer publishes a wide range of content including politics, business, sports and entertainment on and about Liberia. Follow us on social media for all the latest news and analysis. <div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#44282d2621362d252a2b26372136322136042329252d286a272b29"><span class="__cf_email__" data-cfemail="f79b9e9592859e96999895849285819285b7909a969e9bd994989a">[email&#160;protected]</span></a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/pages/Liberian-Observer-Online/42279623238" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/libobserver/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.titter.com/libobserver" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/locmultimedia" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span></aside></div> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="td-subfooter-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-28852"><a href="https://www.scribd.com/Liberian%20Daily%20Observer">E-Edition</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-28964"><a href="https://www.liberianobserver.com/wp-login.php">Login</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home td-menu-item td-normal-menu menu-item-28965"><a href="https://www.liberianobserver.com">Advertisements</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home td-menu-item td-normal-menu menu-item-28966"><a href="https://www.liberianobserver.com">Archives</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-69499"><a href="https://www.liberianobserver.com/opportunities/">Opportunities</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
&copy; Liberian Observer Corporation </div>
</div>
</div>
</div>
</div>
<div style="display:none">
<div class="grofile-hash-map-5e9b534a27f656df74010f2d4f482a19">
</div>
</div>
<div class="td-more-articles-box">
<i class="td-icon-close td-close-more-articles-box"></i>
<span class="td-more-articles-box-title">MORE STORIES</span>
<div class="td-content-more-articles-box">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/major-step-toward-green-card-u-s-citizenship-for-liberians-on-ded/" rel="bookmark" class="td-image-wrap" title="Major Step toward Green Card, U.S. Citizenship for Liberians on DED"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Major Step toward Green Card, U.S. Citizenship for Liberians on DED" data-type="image_tag" data-img-url="https://i0.wp.com/www.liberianobserver.com/wp-content/uploads/2019/10/Liberian-DED-holders-and-their-allies-protest-in-Worcester-Massachusetts.jpg?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/major-step-toward-green-card-u-s-citizenship-for-liberians-on-ded/" rel="bookmark" title="Major Step toward Green Card, U.S. Citizenship for Liberians on DED">Major Step toward Green Card, U.S. Citizenship for Liberians on DED</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-12-14T05:00:19+00:00">December 14, 2019</time></span> </div>
</div>
</div>
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.liberianobserver.com/news/lawmakers-want-cbl-officials-appear-for-questioning/" rel="bookmark" class="td-image-wrap" title="Lawmakers Want CBL Officials Appear for Questioning  "><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Lawmakers Want CBL Officials Appear for Questioning  " data-type="image_tag" data-img-url="https://i1.wp.com/www.liberianobserver.com/wp-content/uploads/2019/12/The-lawmakers-argued-that-they-singed-a-resolution-to-change-the-family-of-banknotes-on-the-market-not-to-print-additional-money-of-the-kind-already-in-circulation-1-1-e1576198100206.jpg?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.liberianobserver.com/news/lawmakers-want-cbl-officials-appear-for-questioning/" rel="bookmark" title="Lawmakers Want CBL Officials Appear for Questioning  ">Lawmakers Want CBL Officials Appear for Questioning  </a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-12-13T02:30:13+00:00">December 13, 2019</time></span> </div>
</div>
</div>
</div>
</div>


<style type="text/css" media="screen">
/* custom css theme panel */
.block-title{border-color: #4db2ec !important;
}
.block-title > span {background-color: #4db2ec !important;}
</style>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
window.WPCOM_sharing_counts = {"https:\/\/www.liberianobserver.com\/opinion\/editorials\/let-not-the-baghdad-bobs-ask-for-whom-the-bells-toll\/":139499};
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.9.1/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/bootstrap-modals/js/bootstrap.min.js?ver=3.3.7'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/jquery/ui/datepicker.min.js'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201951'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var superpwa_sw = {"url":"\/OneSignalSDKWorker.js.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/super-progressive-web-apps/public/js/register-sw.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Decaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.9.1/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=c8cba5620a72d5b299fa8f62aeca6adfx'></script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.2'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.9.1/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=13.1.2.4'></script>
<script type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=c8cba5620a72d5b299fa8f62aeca6adfx'></script>
<script async="async" type='text/javascript' src='https://www.liberianobserver.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.9.1/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
// If there's another sharing window open, close it.
if ( 'undefined' !== typeof windowOpen ) {
windowOpen.close();
}
windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
return false;
});
var windowOpen;
jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
// If there's another sharing window open, close it.
if ( 'undefined' !== typeof windowOpen ) {
windowOpen.close();
}
windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
return false;
});
</script>

<style type="text/css">
.su-spoiler-style-fancy>.su-spoiler-content{ display: flex;}
</style>


<script>
</script>

<style>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</style>
<!--[if IE]>
<script type="text/javascript">
if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
// window.location.reload() doesn't respect the Hash in IE
window.location.hash = window.location.hash;
}
</script>
<![endif]-->
<script type="text/javascript">
(function () {
var comm_par_el = document.getElementById( 'comment_parent' ),
comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
frame = document.getElementById( 'jetpack_remote_comment' ),
tellFrameNewParent;
tellFrameNewParent = function () {
if ( comm_par ) {
frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=125373089&postid=139499&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=dcf2b5f28ed1b81facc8f74e09b5d673729d5383#parent=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Feditorials%2Flet-not-the-baghdad-bobs-ask-for-whom-the-bells-toll%2F%3Futm_campaign%3Dcoschedule%26utm_content%3DLet%2BNot%2Bthe%2BBaghdad%2BBobs%2BAsk%2BFor%2BWhom%2Bthe%2BBells%2BToll%2521%26utm_medium%3DLiberian%2BObserver%2BOnline%26utm_source%3Dfacebook_page" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
} else {
frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=125373089&postid=139499&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=dcf2b5f28ed1b81facc8f74e09b5d673729d5383#parent=https%3A%2F%2Fwww.liberianobserver.com%2Fopinion%2Feditorials%2Flet-not-the-baghdad-bobs-ask-for-whom-the-bells-toll%2F%3Futm_campaign%3Dcoschedule%26utm_content%3DLet%2BNot%2Bthe%2BBaghdad%2BBobs%2BAsk%2BFor%2BWhom%2Bthe%2BBells%2BToll%2521%26utm_medium%3DLiberian%2BObserver%2BOnline%26utm_source%3Dfacebook_page";
}
};
if ( 'undefined' !== typeof addComment ) {
addComment._Jetpack_moveForm = addComment.moveForm;
addComment.moveForm = function ( commId, parentId, respondId, postId ) {
var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
cancelClick, cancel;
if ( false === returnValue ) {
cancel = document.getElementById( 'cancel-comment-reply-link' );
cancelClick = cancel.onclick;
cancel.onclick = function () {
var cancelReturn = cancelClick.call( this );
if ( false !== cancelReturn ) {
return cancelReturn;
}
if ( ! comm_par ) {
return cancelReturn;
}
comm_par = 0;
tellFrameNewParent();
return cancelReturn;
};
}
if ( comm_par == parentId ) {
return returnValue;
}
comm_par = parentId;
tellFrameNewParent();
return returnValue;
};
}
// Do the post message bit after the dom has loaded.
document.addEventListener( 'DOMContentLoaded', function () {
var iframe_url = "https:\/\/jetpack.wordpress.com";
if ( window.postMessage ) {
if ( document.addEventListener ) {
window.addEventListener( 'message', function ( event ) {
var origin = event.origin.replace( /^http:\/\//i, 'https://' );
if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
return;
}
jQuery( frame ).height( event.data );
});
} else if ( document.attachEvent ) {
window.attachEvent( 'message', function ( event ) {
var origin = event.origin.replace( /^http:\/\//i, 'https://' );
if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
return;
}
jQuery( frame ).height( event.data );
});
}
}
})
})();
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201951.js' async='async' defer='defer'></script>
<script type='text/javascript'>
_stq = window._stq || [];
_stq.push([ 'view', {v:'ext',j:'1:7.9.1',blog:'125373089',post:'139499',tz:'0',srv:'www.liberianobserver.com'} ]);
_stq.push([ 'clickTrackerInit', '125373089', '139499' ]);
</script>
</body>
</html>